summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/alephone-infinity')
-rw-r--r--games-fps/alephone-infinity/Manifest2
-rw-r--r--games-fps/alephone-infinity/alephone-infinity-20080622.ebuild41
-rw-r--r--games-fps/alephone-infinity/metadata.xml5
3 files changed, 48 insertions, 0 deletions
diff --git a/games-fps/alephone-infinity/Manifest b/games-fps/alephone-infinity/Manifest
new file mode 100644
index 000000000000..d038c6e33917
--- /dev/null
+++ b/games-fps/alephone-infinity/Manifest
@@ -0,0 +1,2 @@
+DIST MarathonInfinity.zip 30109883 SHA256 e8294df4dcd81b11d74ceedd6d13580ea13ca62d3952eb535b009387a9a4b90a SHA512 1f347615b96d2c07914cda78bdc6971311f3933af78debfcd9fa87a0a3048220726a082602b7a76f516f7b3dd3240d1ea843794ab34e4e9e7733342d9d9fe5b1 WHIRLPOOL a8fefe0dc8c625fcb2fba9da65148d622513189bbb62ae27545b27f39d610f96045498aeabe1a2b35487524e078041e14a17089dda488280fc038a6191ce0710
+DIST alephone-infinity.png 19193 SHA256 cb2e18364347b5e4e256401f2fd9b35b92ed3763375f2f4ea2c190915a7df5c0 SHA512 ad5c683aae4ee0afa306aaf33c9ad93a2eee59a4283166aada58a48a8dbbe8de62c8af0b04b143366448ef101ba8b2530cbc8bc5b3e1de62c5177775fae6bfd3 WHIRLPOOL b1179b771dc2b43823a648eb44b8197c3d777976820cc6650a7be7e8e415bfdff77b76a5331f9f56e8e49b7efd5df335b98f72e2e0645beb0c317e12706640c5
diff --git a/games-fps/alephone-infinity/alephone-infinity-20080622.ebuild b/games-fps/alephone-infinity/alephone-infinity-20080622.ebuild
new file mode 100644
index 000000000000..2b09ffc0a799
--- /dev/null
+++ b/games-fps/alephone-infinity/alephone-infinity-20080622.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Aleph One - Marathon Infinity"
+HOMEPAGE="http://trilogyrelease.bungie.org/"
+SRC_URI="http://files3.bungie.org/trilogy/MarathonInfinity.zip
+ mirror://gentoo/${PN}.png"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Marathon\ Infinity
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r *
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry "alephone.sh infinity" "Aleph One - Marathon Infinity"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${GAMES_DATADIR}"/${PN}/{Scripts,"Physics Models",Textures,Themes}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play this scenario, run:"
+ elog "alephone.sh infinity"
+}
diff --git a/games-fps/alephone-infinity/metadata.xml b/games-fps/alephone-infinity/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/alephone-infinity/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>