summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/alephone')
-rw-r--r--games-fps/alephone/Manifest2
-rw-r--r--games-fps/alephone/alephone-20100424.ebuild97
-rw-r--r--games-fps/alephone/alephone-20120514.ebuild97
-rw-r--r--games-fps/alephone/files/alephone-20100424-boost_145.patch10
-rw-r--r--games-fps/alephone/files/alephone-20100424-gcc47.patch11
-rw-r--r--games-fps/alephone/files/alephone-20100424-png15.patch19
-rw-r--r--games-fps/alephone/files/alephone-20120514-gcc47.patch11
-rw-r--r--games-fps/alephone/files/alephone-20120514-png15.patch11
-rw-r--r--games-fps/alephone/files/alephone.sh28
-rw-r--r--games-fps/alephone/metadata.xml8
10 files changed, 294 insertions, 0 deletions
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
new file mode 100644
index 000000000000..4e0f40d026f6
--- /dev/null
+++ b/games-fps/alephone/Manifest
@@ -0,0 +1,2 @@
+DIST AlephOne-20100424.tar.bz2 3180896 SHA256 d97089890ce99952027eaf6185baa6cb01b26c2882dfca9e68816dfe7076a5e6 SHA512 b246b662f4bf820238c09fbb6bc55289d0db0a9b5ba15ab2b91a53f93666e81583834fd8a64497074a2e270a2055de24b3be93bb56d58715f9d213b1f4c92494 WHIRLPOOL 3074f6c4ba4925b8a0f7718bdfb0d1084155421397a7604febfeae473635b970b3842152b9a3e200f2bc642790a0dc51e689aa3b18de2235d5697105060c7f93
+DIST AlephOne-20120514.tar.bz2 4716348 SHA256 6a7797af74cf3fae7f5505e64ffe57c56f7331521cb569bcc8b7d7041cb3718b SHA512 71e54341221485765b63c7c723f95e04d41c8e2cecf6bc3f885efc178f4c75fd88cdffe703c4bf41a5e7101fd8cef33797d00cd249e211b7de1b22fc639b4278 WHIRLPOOL 03ff5bd735a28a3113706f4de5837351404ddede2fabc09d45233b3bb646a9550f00cc1d30710a6f32952c452668e5f764fb427ef5495553f6c49ddcfcaef350
diff --git a/games-fps/alephone/alephone-20100424.ebuild b/games-fps/alephone/alephone-20100424.ebuild
new file mode 100644
index 000000000000..c58e340efd89
--- /dev/null
+++ b/games-fps/alephone/alephone-20100424.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils games
+
+MY_P=AlephOne-${PV}
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="alsa mad mpeg sndfile speex truetype vorbis"
+
+RDEPEND="media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libsdl[video]
+ dev-libs/expat
+ dev-libs/zziplib
+ media-libs/libpng:0
+ alsa? ( media-libs/alsa-lib )
+ mad? ( media-libs/libmad )
+ mpeg? ( media-libs/smpeg )
+ virtual/opengl
+ virtual/glu
+ sndfile? ( media-libs/libsndfile )
+ speex? ( media-libs/speex )
+ truetype? ( media-libs/sdl-ttf )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+ "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
+ || die
+
+ # try using the system expat - bug #251108
+ sed -i \
+ -e '/SUBDIRS/ s/Expat//' \
+ -e 's/Expat\/libexpat.a/-lexpat/' \
+ Source_Files/Makefile.am \
+ || die
+ sed -i \
+ -e '/Expat/d' \
+ configure.ac \
+ || die
+ rm -rf Source_Files/Expat
+
+ # for automake 1.12 compability - bug #422557
+ sed -i -e 's:AC_PROG_CC:&\nAC_PROG_OBJCXX:' configure.ac || die
+
+ epatch \
+ "${FILESDIR}"/${P}-boost_145.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-png15.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --enable-lua \
+ $(use_enable alsa) \
+ $(use_enable mad) \
+ $(use_enable mpeg smpeg) \
+ --enable-opengl \
+ $(use_enable sndfile) \
+ $(use_enable speex) \
+ $(use_enable truetype ttf) \
+ $(use_enable vorbis)
+}
+
+src_install() {
+ default
+ dogamesbin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ dohtml docs/*.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Read the docs and install the data files accordingly to play."
+ echo
+ elog "If you only want to install one scenario, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Single_scenario_3"
+ elog "If you want to install multiple scenarios, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/alephone-20120514.ebuild b/games-fps/alephone/alephone-20120514.ebuild
new file mode 100644
index 000000000000..f08adb710dcd
--- /dev/null
+++ b/games-fps/alephone/alephone-20120514.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+MY_P=AlephOne-${PV}
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa mad mpeg sndfile speex truetype vorbis"
+
+RDEPEND="media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libsdl[video]
+ dev-libs/expat
+ dev-libs/zziplib
+ media-libs/libpng:0
+ alsa? ( media-libs/alsa-lib )
+ mad? ( media-libs/libmad )
+ mpeg? ( media-libs/smpeg )
+ virtual/opengl
+ virtual/glu
+ sndfile? ( media-libs/libsndfile )
+ speex? ( media-libs/speex )
+ truetype? ( media-libs/sdl-ttf )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+ "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
+ || die
+
+ # try using the system expat - bug #251108
+ sed -i \
+ -e '/SUBDIRS/ s/Expat//' \
+ -e 's/Expat\/libexpat.a/-lexpat/' \
+ Source_Files/Makefile.am \
+ || die
+ sed -i \
+ -e '/Expat/d' \
+ configure.ac \
+ || die
+ rm -r Source_Files/Expat || die
+
+ # for automake 1.12 compability - bug #422557
+ sed -i -e 's:AC_PROG_CC:&\nAC_PROG_OBJCXX:' configure.ac || die
+
+ epatch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-png15.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --enable-lua \
+ $(use_enable alsa) \
+ $(use_enable mad) \
+ $(use_enable mpeg smpeg) \
+ --enable-opengl \
+ $(use_enable sndfile) \
+ $(use_enable speex) \
+ $(use_enable truetype ttf) \
+ $(use_enable vorbis)
+}
+
+src_install() {
+ default
+ dogamesbin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ dohtml docs/*.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Read the docs and install the data files accordingly to play."
+ echo
+ elog "If you only want to install one scenario, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Single_scenario_3"
+ elog "If you want to install multiple scenarios, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/files/alephone-20100424-boost_145.patch b/games-fps/alephone/files/alephone-20100424-boost_145.patch
new file mode 100644
index 000000000000..30d8b78594df
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20100424-boost_145.patch
@@ -0,0 +1,10 @@
+--- Source_Files/Network/Metaserver/network_metaserver.h.old 2011-01-20 23:29:21.000000000 +0100
++++ Source_Files/Network/Metaserver/network_metaserver.h 2011-01-20 23:30:07.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include <map>
+ #include <memory> // auto_ptr
+ #include <set>
++#include <stdexcept>
+
+ #include "Logging.h"
+
diff --git a/games-fps/alephone/files/alephone-20100424-gcc47.patch b/games-fps/alephone/files/alephone-20100424-gcc47.patch
new file mode 100644
index 000000000000..1347d64592f9
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20100424-gcc47.patch
@@ -0,0 +1,11 @@
+--- Source_Files/Lua/lua_templates.h.old 2012-10-15 09:55:32.395310163 +0200
++++ Source_Files/Lua/lua_templates.h 2012-10-15 09:56:14.991129122 +0200
+@@ -496,7 +496,7 @@
+ static index_t ToIndex(lua_State *L, int index) {
+ index_t to;
+ if(lua_isnil(L, index)) return -1;
+- else if(_lookup(L, index, to)) return to;
++ else if(L_LazyEnum::_lookup(L, index, to)) return to;
+ else {
+ std::string error;
+ if(lua_isnumber(L, index) || lua_isstring(L, index))
diff --git a/games-fps/alephone/files/alephone-20100424-png15.patch b/games-fps/alephone/files/alephone-20100424-png15.patch
new file mode 100644
index 000000000000..da99a8454102
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20100424-png15.patch
@@ -0,0 +1,19 @@
+--- Source_Files/RenderOther/IMG_savepng.c.old 2011-09-13 10:20:56.395157142 +0200
++++ Source_Files/RenderOther/IMG_savepng.c 2011-09-13 10:23:00.630142397 +0200
+@@ -29,6 +29,7 @@
+ #include <SDL/SDL.h>
+ #include <SDL/SDL_byteorder.h>
+ #include <png.h>
++#include <zlib.h>
+ #include "IMG_savepng.h"
+
+ int IMG_SavePNG(const char *file, SDL_Surface *surf,int compression, struct IMG_PNG_text* text, int num_text){
+@@ -85,7 +86,7 @@
+ goto savedone;
+ }
+ /* setup custom writer functions */
+- png_set_write_fn(png_ptr,(voidp)src,png_write_data,NULL);
++ png_set_write_fn(png_ptr,(png_voidp)src,png_write_data,NULL);
+
+ if (setjmp(png_jmpbuf(png_ptr))){
+ SDL_SetError("Unknown error writing PNG");
diff --git a/games-fps/alephone/files/alephone-20120514-gcc47.patch b/games-fps/alephone/files/alephone-20120514-gcc47.patch
new file mode 100644
index 000000000000..0f6cac2e94c7
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20120514-gcc47.patch
@@ -0,0 +1,11 @@
+--- AlephOne-20120514/Source_Files/Lua/lua_templates.h
++++ AlephOne-20120514/Source_Files/Lua/lua_templates.h
+@@ -496,7 +496,7 @@
+ static index_t ToIndex(lua_State *L, int index) {
+ index_t to;
+ if(lua_isnil(L, index)) return -1;
+- else if(_lookup(L, index, to)) return to;
++ else if(L_LazyEnum::_lookup(L, index, to)) return to;
+ else {
+ std::string error;
+ if(lua_isnumber(L, index) || lua_isstring(L, index))
diff --git a/games-fps/alephone/files/alephone-20120514-png15.patch b/games-fps/alephone/files/alephone-20120514-png15.patch
new file mode 100644
index 000000000000..bb99d7ed3245
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20120514-png15.patch
@@ -0,0 +1,11 @@
+--- AlephOne-20120514/Source_Files/RenderOther/IMG_savepng.c
++++ AlephOne-20120514/Source_Files/RenderOther/IMG_savepng.c
+@@ -86,7 +86,7 @@ int IMG_SavePNG_RW(SDL_RWops *src, SDL_S
+ goto savedone;
+ }
+ /* setup custom writer functions */
+- png_set_write_fn(png_ptr,(voidp)src,png_write_data,NULL);
++ png_set_write_fn(png_ptr,(png_voidp)src,png_write_data,NULL);
+
+ if (setjmp(png_jmpbuf(png_ptr))){
+ SDL_SetError("Unknown error writing PNG");
diff --git a/games-fps/alephone/files/alephone.sh b/games-fps/alephone/files/alephone.sh
new file mode 100644
index 000000000000..62ac98f85770
--- /dev/null
+++ b/games-fps/alephone/files/alephone.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+DIR=$(dirname "${0}")
+CMD=$(basename "${0}")
+ALEPHONE=${CMD%%.sh}
+
+if [[ -z "${1}" ]]
+then
+ echo "Usage: ${0} SCENARIO FLAGS"
+ echo "Where SCENARIO is one of:"
+ for d in "GAMES_DATADIR"/alephone-*
+ do
+ echo " ${d##*/alephone-}"
+ done
+ exit 2
+fi
+
+export ALEPHONE_DATA="GAMES_DATADIR/alephone-${1}"
+
+shift
+
+# kill ARTS, because we're just that nice
+if artsshell terminate 2> /dev/null
+then
+ sleep 2
+fi
+
+"${DIR}"/"${ALEPHONE}" "$@"
diff --git a/games-fps/alephone/metadata.xml b/games-fps/alephone/metadata.xml
new file mode 100644
index 000000000000..c69d4eeed595
--- /dev/null
+++ b/games-fps/alephone/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">marathon</remote-id>
+ </upstream>
+</pkgmetadata>