summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quakeforge/quakeforge-0.7.2_p20210722.ebuild6
-rw-r--r--games-fps/quakeforge/quakeforge-9999.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/games-fps/quakeforge/quakeforge-0.7.2_p20210722.ebuild b/games-fps/quakeforge/quakeforge-0.7.2_p20210722.ebuild
index 1a58d8f86151..00b38e91bb28 100644
--- a/games-fps/quakeforge/quakeforge-0.7.2_p20210722.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.7.2_p20210722.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools readme.gentoo-r1 toolchain-funcs
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -68,6 +68,8 @@ src_prepare() {
}
src_configure() {
+ filter-lto #858755
+
qf_client() {
echo $(usex client $(use_enable ${1}) --disable-${1})
}
diff --git a/games-fps/quakeforge/quakeforge-9999.ebuild b/games-fps/quakeforge/quakeforge-9999.ebuild
index 5a6d465477c4..8b48e19f6810 100644
--- a/games-fps/quakeforge/quakeforge-9999.ebuild
+++ b/games-fps/quakeforge/quakeforge-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools readme.gentoo-r1 toolchain-funcs
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -70,6 +70,8 @@ src_prepare() {
}
src_configure() {
+ filter-lto #858755
+
qf_client() {
usex client $(use_enable ${1}) --disable-${1}
}