summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/freedoom-data/Manifest1
-rw-r--r--games-fps/freedoom-data/freedoom-data-0.11.3.ebuild29
-rw-r--r--games-fps/freedoom-data/metadata.xml42
3 files changed, 72 insertions, 0 deletions
diff --git a/games-fps/freedoom-data/Manifest b/games-fps/freedoom-data/Manifest
new file mode 100644
index 000000000000..d3ca3066e926
--- /dev/null
+++ b/games-fps/freedoom-data/Manifest
@@ -0,0 +1 @@
+DIST freedoom-0.11.3.zip 18889307 BLAKE2B 052d7f58d1beb7947f4fff3021ec0229c9746bfb7970a52d23fa44fc881d8cf3c314b8ecf0dc400c2da4e28c623695874ae75dcd1e45933fdb1826ea04f0e24b SHA512 c67fc69bca87cba2ba40b91f578724feaabbd6cd64c6845fa567d6901b7a9e3145185011731c677a71f7b5a6f8707855fb573c0c09b6d47fef83b1577b211816
diff --git a/games-fps/freedoom-data/freedoom-data-0.11.3.ebuild b/games-fps/freedoom-data/freedoom-data-0.11.3.ebuild
new file mode 100644
index 000000000000..5e38d534c7e2
--- /dev/null
+++ b/games-fps/freedoom-data/freedoom-data-0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Game resources for Freedoom: Phase 1+2"
+HOMEPAGE="https://freedoom.github.io"
+SRC_URI="https://github.com/freedoom/freedoom/releases/download/v${PV}/freedoom-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/freedoom-${PV}"
+
+DOOMWADPATH=/usr/share/doom
+
+src_install() {
+ insinto ${DOOMWADPATH}
+ doins freedoom1.wad
+ doins freedoom2.wad
+ dodoc CREDITS.txt README.html
+}
+
+pkg_postinst() {
+ elog "Freedoom WAD files installed into ${DOOMWADPATH} directory."
+}
diff --git a/games-fps/freedoom-data/metadata.xml b/games-fps/freedoom-data/metadata.xml
new file mode 100644
index 000000000000..08a722785b1d
--- /dev/null
+++ b/games-fps/freedoom-data/metadata.xml
@@ -0,0 +1,42 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ The Freedoom project aims to create a complete free content first person
+ shooter game. But Freedoom by itself is just the raw material for a
+ game: it must be paired with a compatible game engine to be played.
+
+ id Software released the source code to their classic game, Doom, under
+ the GNU General Public License. This means that the program code that
+ powers Doom is free; Freedoom complements this with free levels,
+ artwork, sound effects and music to make a completely free game.
+
+ Phase 1 is the first part of the single-player game, containing four
+ chapters which are nine levels each, smoothly paced for beginner
+ players. It is compatible with mods for the original Doom and The
+ Ultimate Doom.
+
+ Phase 2 is the second major part of the single-player game, a massive
+ 32-level chapter expanding upon the same concepts present in Phase 1, as
+ well as containing additional monsters and the double-barreled shotgun!
+ The levels in this game tend to demand more skillful play than the
+ previous chapters. It is compatible with mods for Doom II.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/freedoom/freedoom/issues</bugs-to>
+ <doc lang="en">https://freedoom.github.io</doc>
+ <remote-id type="github">freedoom/freedoom</remote-id>
+ </upstream>
+</pkgmetadata>