summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom-data/doom-data-1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-fps/doom-data/doom-data-1-r2.ebuild b/games-fps/doom-data/doom-data-1-r2.ebuild
new file mode 100644
index 000000000000..dcbff4655ed9
--- /dev/null
+++ b/games-fps/doom-data/doom-data-1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Collection of doom wad files from id"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="mirror://gentoo/doom1.wad.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doomsday"
+
+RDEPEND="doomsday? ( games-fps/doomsday )"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/doom-data
+ doins *.wad
+ if use doomsday; then
+ # Make wrapper for doomsday
+ make_wrapper doomsday-demo "jdoom -file \
+ /usr/share/doom-data/doom1.wad"
+ make_desktop_entry doomsday-demo "Doomsday - Demo"
+ fi
+}
+
+pkg_postinst() {
+ if use doomsday; then
+ elog "To use the doomsday engine, run doomsday-demo"
+ else
+ elog "A Doom engine is required to play the wad"
+ elog "Enable the doomsday use flag if you want to use"
+ elog " the doomsday engine"
+ fi
+}