summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quakeforge/quakeforge-0.7.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-fps/quakeforge/quakeforge-0.7.2.ebuild b/games-fps/quakeforge/quakeforge-0.7.2.ebuild
index 91a109daa133..1bcffe26f361 100644
--- a/games-fps/quakeforge/quakeforge-0.7.2.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.7.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils autotools games
+inherit eutils flag-o-matic autotools games
DESCRIPTION="new 3d engine based off of id Softwares's Quake and QuakeWorld game engine"
HOMEPAGE="http://www.quakeforge.net/"
@@ -47,6 +47,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #570392)
}
src_configure() {