summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/gmult-8.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-kids/gmult/gmult-8.0-r1.ebuild b/games-kids/gmult/gmult-8.0-r1.ebuild
new file mode 100644
index 000000000000..8ab30c916a1c
--- /dev/null
+++ b/games-kids/gmult/gmult-8.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils flag-o-matic
+
+DESCRIPTION="Multiplication Puzzle is a simple GTK+ 2 game that emulates the multiplication game found in Emacs"
+HOMEPAGE="http://www.mterry.name/gmult/"
+SRC_URI="https://launchpad.net/gmult/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:3
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ append-libs -lm
+ econf # \
+ #--bindir="${GAMES_BINDIR}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}