summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/bsd-games')
-rw-r--r--games-misc/bsd-games/bsd-games-3.1-r2.ebuild (renamed from games-misc/bsd-games/bsd-games-3.1-r1.ebuild)10
1 files changed, 4 insertions, 6 deletions
diff --git a/games-misc/bsd-games/bsd-games-3.1-r1.ebuild b/games-misc/bsd-games/bsd-games-3.1-r2.ebuild
index 68e5a80674f7..ba3c5f5dd7c4 100644
--- a/games-misc/bsd-games/bsd-games-3.1-r1.ebuild
+++ b/games-misc/bsd-games/bsd-games-3.1-r2.ebuild
@@ -22,7 +22,7 @@ RESTRICT="test"
DEPEND="
sys-apps/miscfiles
- sys-libs/ncurses:=
+ sys-libs/ncurses:=[unicode(+)]
!games-puzzle/hangman
!games-misc/wumpus
"
@@ -60,10 +60,8 @@ src_prepare() {
# Yes, this stinks.
# Right now, the custom configure script calls pkg-config manually
# and seds it a bunch, and this is easier.
- if has_version sys-libs/ncurses[unicode] ; then
- # Force looking for both ncurses and ncursesw
- sed -i -e 's/pkgs="ncurses"/pkgs="ncursesw"/' configure || die
- fi
+ # Force looking for both ncurses and ncursesw
+ sed -i -e 's/pkgs="ncurses"/pkgs="ncursesw"/' configure || die
cp "${FILESDIR}"/config.params-gentoo config.params || die
echo bsd_games_cfg_usrlibdir=\"$(get_libdir)\" >> ./config.params || die
@@ -151,5 +149,5 @@ src_install() {
fowners -R :gamestat /usr/bin/
# State dirs
- chmod -R ug+rw "${ED}"/var/games/ || die
+ fperms -R ug+rw /var/games/
}