summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/cowsay/cowsay-3.7.0.ebuild')
-rw-r--r--games-misc/cowsay/cowsay-3.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-misc/cowsay/cowsay-3.7.0.ebuild b/games-misc/cowsay/cowsay-3.7.0.ebuild
new file mode 100644
index 000000000000..e50f98fd85bd
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Configurable talking ASCII cow (and other characters)"
+HOMEPAGE="https://cowsay.diamonds https://github.com/cowsay-org/cowsay"
+SRC_URI="https://github.com/cowsay-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~mips ~ppc64 ~x86 ~x64-macos ~x64-solaris"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.7-head-in.patch"
+ "${FILESDIR}/${PN}-3.0.7-mech-and-cow.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's#/usr/local#/${EPREFIX}/usr#' Makefile || die
+}