summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/nyancat')
-rw-r--r--games-misc/nyancat/Manifest1
-rw-r--r--games-misc/nyancat/metadata.xml8
-rw-r--r--games-misc/nyancat/nyancat-1.2.1.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/games-misc/nyancat/Manifest b/games-misc/nyancat/Manifest
new file mode 100644
index 000000000000..de59210dd015
--- /dev/null
+++ b/games-misc/nyancat/Manifest
@@ -0,0 +1 @@
+DIST nyancat-1.2.1.tar.gz 14109 SHA256 a5bfafb6ea69917071aa05f9a52db43e47e97272eb2f4c6c827630cddb015972 SHA512 882bdcfe702d4613484b293f767a2ed74da63f222071e59f56a4246f56947882540930bcb2deae22f6e3326064f1c6f0ff7eb78ac6d7aa08125ebe64ebdf16eb WHIRLPOOL 3c263a35cee24babac92b3ed6ec33a8a4324adcec3364ffef2d0a3ac01786689a9969a21fde3ce1d278f572cd204be336d32d2411168bf6ac46ae47de20a5204
diff --git a/games-misc/nyancat/metadata.xml b/games-misc/nyancat/metadata.xml
new file mode 100644
index 000000000000..bc44a06a0e1e
--- /dev/null
+++ b/games-misc/nyancat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="github">klange/nyancat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/nyancat/nyancat-1.2.1.ebuild b/games-misc/nyancat/nyancat-1.2.1.ebuild
new file mode 100644
index 000000000000..9bfc7f48e1e8
--- /dev/null
+++ b/games-misc/nyancat/nyancat-1.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Nyan Cat Telnet Server"
+HOMEPAGE="http://github.com/klange/nyancat"
+SRC_URI="https://github.com/klange/nyancat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS} ${CFLAGS}"
+}
+
+src_install() {
+ dogamesbin src/${PN}
+ dodoc README.md
+ prepgamesdirs
+}