summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/concentration/concentration-1.2-r2.ebuild')
-rw-r--r--games-puzzle/concentration/concentration-1.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-puzzle/concentration/concentration-1.2-r2.ebuild b/games-puzzle/concentration/concentration-1.2-r2.ebuild
new file mode 100644
index 000000000000..5233b13dc8d8
--- /dev/null
+++ b/games-puzzle/concentration/concentration-1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="The classic memory game with some new life"
+HOMEPAGE="https://packages.gentoo.org/package/games-puzzle/concentration"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_install() {
+ default
+ newicon pics/set1/19.png ${PN}.png
+ make_desktop_entry ${PN} Concentration
+}