summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gottet/gottet-1.1.6.ebuild')
-rw-r--r--games-puzzle/gottet/gottet-1.1.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/gottet/gottet-1.1.6.ebuild b/games-puzzle/gottet/gottet-1.1.6.ebuild
new file mode 100644
index 000000000000..0d95a54b6a90
--- /dev/null
+++ b/games-puzzle/gottet/gottet-1.1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+DESCRIPTION="A tetris clone based on Qt5"
+HOMEPAGE="https://gottcode.org/gottet/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}