summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gtkballs/gtkballs-3.1.5-r1.ebuild')
-rw-r--r--games-puzzle/gtkballs/gtkballs-3.1.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/gtkballs/gtkballs-3.1.5-r1.ebuild b/games-puzzle/gtkballs/gtkballs-3.1.5-r1.ebuild
new file mode 100644
index 000000000000..fade6e04911c
--- /dev/null
+++ b/games-puzzle/gtkballs/gtkballs-3.1.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="An entertaining game based on the old DOS game lines"
+HOMEPAGE="http://gtkballs.antex.ru/"
+SRC_URI="http://gtkballs.antex.ru/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_prepare() {
+ sed -i \
+ -e '/^nlsdir=/s:=.*:=/usr/share/locale:' \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ configure po/Makefile.in.in || die "sed locale failed"
+}
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon gnome-gtkballs.png ${PN}.png
+ make_desktop_entry gtkballs "GTK Balls"
+ prepgamesdirs
+}