summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch')
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
index ab772d8c72e9..ac329c0dd58d 100644
--- a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
+++ b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
@@ -1,5 +1,5 @@
# Work around Gentoo's crippled dash
-
+# Also add "$@" to accept options
--- pingus-0.7.6/Makefile
+++ pingus-0.7.6/Makefile
@@ -39,7 +39,7 @@
@@ -7,7 +7,7 @@
install -D build/pingus "$(DESTDIR)$(BINDIR)/pingus.bin"
- echo -e "#!/bin/sh\nexec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
-+ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
++ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\" \"\$$@\"" > "$(DESTDIR)$(BINDIR)/pingus"
chmod 755 "$(DESTDIR)$(BINDIR)/pingus"
install-data: