summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hangman/hangman-0.9.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/hangman/hangman-0.9.2-r1.ebuild b/games-puzzle/hangman/hangman-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..abfc77ca017b
--- /dev/null
+++ b/games-puzzle/hangman/hangman-0.9.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="The classic word guessing game"
+HOMEPAGE="http://www.shiftygames.com/hangman/hangman.html"
+SRC_URI="http://www.shiftygames.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!games-misc/bsd-games
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}
+ sys-apps/miscfiles"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/hangman.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ newicon pics/noose.png ${PN}.png
+ make_desktop_entry ${PN} Hangman
+}