summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/construo/construo-0.2.2-r1.ebuild38
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch28
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-lGLU.patch4
3 files changed, 54 insertions, 16 deletions
diff --git a/games-puzzle/construo/construo-0.2.2-r1.ebuild b/games-puzzle/construo/construo-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..1f7406534412
--- /dev/null
+++ b/games-puzzle/construo/construo-0.2.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="2d construction toy with objects that react on physical forces"
+HOMEPAGE="http://www.nongnu.org/construo/"
+SRC_URI="http://freesoftware.fsf.org/download/construo/construo.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ x11-libs/libXxf86vm
+"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-lGLU.patch
+ sed -i -e 's/^bindir=.*/bindir=@bindir@/' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ make_desktop_entry "${PN}.glut" "${PN}.glut"
+ make_desktop_entry "${PN}.x11" "${PN}.x11"
+}
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
index cc946b043bae..48165ed21df0 100644
--- a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
+++ b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
@@ -1,5 +1,5 @@
---- command_line.cxx
-+++ command_line.cxx
+--- a/command_line.cxx
++++ b/command_line.cxx
@@ -19,7 +19,9 @@
#include <config.h>
@@ -11,8 +11,8 @@
#include "settings.hxx"
#include "command_line.hxx"
---- config.hxx
-+++ config.hxx
+--- a/config.hxx
++++ b/config.hxx
@@ -21,6 +21,7 @@
#define CONFIG_HH
@@ -21,8 +21,8 @@
class Config
{
---- lisp_reader.cxx
-+++ lisp_reader.cxx
+--- a/lisp_reader.cxx
++++ b/lisp_reader.cxx
@@ -17,6 +17,7 @@
// along with this program; if not, write to the Free Software
// Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
@@ -31,8 +31,8 @@
#include "construo_error.hxx"
#include "lisp_reader.hxx"
---- unix_system.cxx
-+++ unix_system.cxx
+--- a/unix_system.cxx
++++ b/unix_system.cxx
@@ -17,8 +17,9 @@
// along with this program; if not, write to the Free Software
// Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
@@ -45,8 +45,8 @@
#include <unistd.h>
#include <sys/time.h>
#include <time.h>
---- vector.cxx
-+++ vector.cxx
+--- a/vector.cxx
++++ b/vector.cxx
@@ -16,8 +16,8 @@
totally replaced old CL_Vector with this code
*/
@@ -58,8 +58,8 @@
#include "vector.hxx"
CL_Vector::CL_Vector(float x, float y, float z, float w)
---- world.cxx
-+++ world.cxx
+--- a/world.cxx
++++ b/world.cxx
@@ -17,7 +17,8 @@
// along with this program; if not, write to the Free Software
// Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
@@ -70,8 +70,8 @@
#include <algorithm>
#include "config.h"
---- x11_display.cxx
-+++ x11_display.cxx
+--- a/x11_display.cxx
++++ b/x11_display.cxx
@@ -19,6 +19,7 @@
#include <config.h>
diff --git a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
index 4c0b018cfdc1..be8e7b604d6f 100644
--- a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
+++ b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
@@ -1,5 +1,5 @@
---- configure.ac.old 2009-11-24 18:27:48.000000000 +0100
-+++ configure.ac 2009-11-24 18:28:29.000000000 +0100
+--- a/configure.ac.old 2009-11-24 18:27:48.000000000 +0100
++++ b/configure.ac 2009-11-24 18:28:29.000000000 +0100
@@ -114,7 +114,7 @@
AC_CHECK_LIB(glut, glutMainLoop,
[