summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/slashem/files')
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/GTK.configure22
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/Gentoo.configure5
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/Proxy.configure24
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/X11.configure18
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/dot.slashemrc112
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/gnome.configure21
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/makefile.patch27
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/opengl.configure10
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/prepare-gui.configure67
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/proxy.slashemrc4
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/qt.configure23
-rw-r--r--games-roguelike/slashem/files/0.0.7E7/sdl.configure16
12 files changed, 349 insertions, 0 deletions
diff --git a/games-roguelike/slashem/files/0.0.7E7/GTK.configure b/games-roguelike/slashem/files/0.0.7E7/GTK.configure
new file mode 100644
index 000000000000..49c14fe6e5a0
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/GTK.configure
@@ -0,0 +1,22 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ undefine GNOME_GRAPHICS
+ define GTK_GRAPHICS
+ define GTK_PROXY
+END
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ undefine WINGNOMESRC
+ undefine WINGNOMEOBJ
+ undefine WINGNOMELIB
+ define WINGTKSRC
+ define WINGTKOBJ
+ define WINGTKLIB
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ undefine CNF_SHARE_GNOMEND
+ define CNF_SHARE_GTKND
+ define CNF_SHARE_GTKPROXYND
+END
diff --git a/games-roguelike/slashem/files/0.0.7E7/Gentoo.configure b/games-roguelike/slashem/files/0.0.7E7/Gentoo.configure
new file mode 100644
index 000000000000..f10d73df2893
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/Gentoo.configure
@@ -0,0 +1,5 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ redefine COMPRESS \"/bin/gzip\"
+END
+
diff --git a/games-roguelike/slashem/files/0.0.7E7/Proxy.configure b/games-roguelike/slashem/files/0.0.7E7/Proxy.configure
new file mode 100644
index 000000000000..56e79cbf3fcb
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/Proxy.configure
@@ -0,0 +1,24 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ define PROXY_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ define WINPROXYSRC
+ define PROXYUTLSRC
+ define PROXYCOMSRC
+ define PROXYCLNTSRC
+
+ define WINPROXYOBJ
+ define PROXYUTLOBJ
+ define PROXYCOMOBJ
+ define PROXYCLNTOBJ
+
+ define WINPROXYLIB
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ define CNF_SHARE_PROXYND
+END
diff --git a/games-roguelike/slashem/files/0.0.7E7/X11.configure b/games-roguelike/slashem/files/0.0.7E7/X11.configure
new file mode 100644
index 000000000000..8c9e362eb9ff
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/X11.configure
@@ -0,0 +1,18 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ define X11_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ define WINX11SRC
+ define WINX11OBJ
+ define WINX11LIB
+ redefine WINX11LIB "-lXaw -lXmu -lXext -lXt -lXpm -lX11"
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ define CNF_SHARE_X11ND
+ redefine CNF_SHARE_X11ND "x11bigtiles x11tiles SlashEM.ad pet_mark.xbm rip.xpm"
+END
diff --git a/games-roguelike/slashem/files/0.0.7E7/dot.slashemrc b/games-roguelike/slashem/files/0.0.7E7/dot.slashemrc
new file mode 100644
index 000000000000..518e8d67addc
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/dot.slashemrc
@@ -0,0 +1,112 @@
+#
+# Slash'EM configuration file.
+#
+# Naming this file $(HOME)/.slashemrc (for UNIX) or setting the environment
+# variable SLASHEMOPTIONS to point to its full path name elsewhere tells
+# Slash'EM to use X11 windowing and fonts (provided the executable was
+# compiled with that ability).
+#
+# SET YOUR WINDOW TYPE
+# Your windowtype choices are: GENTOO_WINDOWTYPES
+#
+OPTIONS=windowtype:tty
+
+TILESET=name:Small, file:x11tiles
+TILESET=name:Big, file:x11bigtiles, transparent
+TILESET=name:Big 3D, file:x11big3dtiles, transparent, pseudo3D
+
+# These tile definitions are used by the SDL/GL interface
+TILESET=name:gl 3D, file:gltile64.png, transparent, pseudo3D
+TILESET=name:gl Big, file:gltile32.png, transparent
+TILESET=name:gl Small, file:gltile16.png, transparent
+
+OPTIONS=tiles:Big
+#
+#
+#OPTIONS=toptenwin,hilite_pet,color,number_pad:2,verbose,news
+#OPTIONS=confirm,fixinv,noautopickup,safe_pet,sortpack,tombstone
+#OPTIONS=fruit:pineapple,dogname:Dhairrhuwyth
+#OPTIONS=male,catname:Ghisteslwchlohm
+#
+# There are 17 object symbols and various graphics symbols.
+# The descriptions of these symbols can be found in dat/opthelp.
+#
+#
+# Font: nh10 (10x20)
+#
+#OBJECTS= 180 183 188 192 181 184 182 189 190 196 \
+# 191 194 193 187 185 186 195
+#
+#DUNGEON= 032 025 018 013 012 014 011 015 023 024 \
+# 022 021 128 129 130 131 132 035 035 133 \
+# 134 135 136 137 145 146 144 124 143 142 \
+# 143 141 140 149 150 031 031 147 148 031 \
+# 161 140
+#
+#TRAPS= 138 138 138 138 138 138 138 138 138 138 \
+# 138 138 138 138 138 139 138 138 138 138 \
+# 138 138
+#
+#EFFECTS= 151 152 153 154 155 156 157 158 \
+# 159 160 161 162 \
+# 163 164 165 166 167 168 169 170 \
+# 171 172 173 174 175 176 177 178 179 \
+# 171 172 173 174 175 176 177 178 179 \
+# 171 172 173 174 175 176 177 178 179 \
+# 171 172 173 174 175 176 177 178 179 \
+# 171 172 173 174 175 176 177 178 179 \
+# 171 172 173 174 175 176 177 178 179 \
+# 171 172 173 174 175 176 177 178 179
+#
+#
+# Font: ibm (8x14)
+#
+#OBJECTS= 207 210 215 219 208 211 209 216 217 223 \
+# 218 221 220 214 212 213 222
+#
+#DUNGEON= 032 128 129 130 131 132 133 134 135 136 \
+# 137 138 139 045 124 142 143 035 035 144 \
+# 145 146 147 148 155 156 227 124 154 153 \
+# 154 152 151 159 160 200 200 157 158 250 \
+# 170 151
+#
+#TRAPS= 149 149 149 149 149 149 149 149 149 149 \
+# 149 149 149 149 149 150 149 149 149 149 \
+# 149 149
+#
+#EFFECTS= 161 162 163 164 165 166 167 168 \
+# 169 170 171 172 \
+# 173 174 175 176 177 178 179 180 \
+# 181 182 183 184 185 186 187 188 189 \
+# 181 182 183 184 185 186 187 188 189 \
+# 181 182 183 184 185 186 187 188 189 \
+# 181 182 183 184 185 186 187 188 189 \
+# 181 182 183 184 185 186 187 188 189 \
+# 181 182 183 184 185 186 187 188 189 \
+# 181 182 183 184 185 186 187 188 189
+#
+#
+# Font: a "standard" font like 6x13
+# Note that this version is unlikely to work on a tty on a Unix system because
+# many of these characters are also control characters.
+#
+#DUNGEON = 032 025 018 013 012 014 011 015 023 024 \
+# 022 021 031 045 124 043 043 035 035 031 \
+# 035 001 060 062 060 062 019 124 092 035 \
+# 092 123 125 031 125 046 046 035 035 046 \
+# 127 125
+#
+#TRAPS= 094 094 094 094 094 094 094 094 094 094 \
+# 094 094 094 094 094 002 094 094 094 094 \
+# 094 094
+#
+#EFFECTS= 124 045 092 047 042 033 041 040 \
+# 048 035 064 042 \
+# 047 045 092 124 124 092 045 047 \
+# 047 064 092 064 064 064 092 064 047 \
+# 047 064 092 064 064 064 092 064 047 \
+# 047 064 092 064 064 064 092 064 047 \
+# 047 064 092 064 064 064 092 064 047 \
+# 047 064 092 064 064 064 092 064 047 \
+# 047 064 092 064 064 064 092 064 047 \
+# 047 064 092 064 064 064 092 064 047
diff --git a/games-roguelike/slashem/files/0.0.7E7/gnome.configure b/games-roguelike/slashem/files/0.0.7E7/gnome.configure
new file mode 100644
index 000000000000..a3178b28d04f
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/gnome.configure
@@ -0,0 +1,21 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ define GNOME_GRAPHICS
+ undefine GTK_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ undefine WINGTKSRC
+ undefine WINGTKOBJ
+ undefine WINGTKLIB
+ define WINGNOMESRC
+ define WINGNOMEOBJ
+ define WINGNOMELIB
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ undefine CNF_SHARE_GTKND
+ define CNF_SHARE_GNOMEND
+END
diff --git a/games-roguelike/slashem/files/0.0.7E7/makefile.patch b/games-roguelike/slashem/files/0.0.7E7/makefile.patch
new file mode 100644
index 000000000000..4f5af5534987
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/makefile.patch
@@ -0,0 +1,27 @@
+diff -Naurd slashem/sys/unix/Makefile.top slashem-0.0.7E6/sys/unix/Makefile.top
+--- slashem/sys/unix/Makefile.top 2003-12-02 13:46:08.000000000 +0200
++++ slashem-0.0.7E6/sys/unix/Makefile.top 2004-03-02 21:08:55.718790760 +0200
+@@ -290,7 +290,7 @@
+ $(MAKE) dofiles-$${target-nodlb}
+ cp src/$(GAME) $(FILE_AREA_UNSHARE)
+ cp util/recover $(FILE_AREA_UNSHARE)
+- cp dat/license doc/Guidebook.txt $(FILE_AREA_DOC)
++# cp dat/license doc/Guidebook.txt $(FILE_AREA_DOC)
+ # cp win/Qt/KDE/kslashem.kdelnk $(KDEDIR)/share/applnk/Games
+ -rm -f $(SHELLDIR)/$(GAME)
+ sed -e 's;/usr/games/lib/nethackdir;$(FILE_AREA_UNSHARE);' \
+@@ -302,10 +302,10 @@
+ $(CHGRP) $(GAMEGRP) $(GAME) recover )
+ chmod $(GAMEPERM) $(FILE_AREA_UNSHARE)/$(GAME)
+ chmod $(EXEPERM) $(FILE_AREA_UNSHARE)/recover
+- -( cd $(FILE_AREA_DOC) ; \
+- $(CHOWN) $(GAMEUID) license Guidebook.txt ; \
+- $(CHGRP) $(GAMEGRP) license Guidebook.txt ; \
+- chmod $(FILEPERM) license Guidebook.txt )
++# -( cd $(FILE_AREA_DOC) ; \
++# $(CHOWN) $(GAMEUID) license Guidebook.txt ; \
++# $(CHGRP) $(GAMEGRP) license Guidebook.txt ; \
++# chmod $(FILEPERM) license Guidebook.txt )
+ -$(CHOWN) $(GAMEUID) $(SHELLDIR)/$(GAME)
+ $(CHGRP) $(GAMEGRP) $(SHELLDIR)/$(GAME)
+ chmod $(EXEPERM) $(SHELLDIR)/$(GAME)
diff --git a/games-roguelike/slashem/files/0.0.7E7/opengl.configure b/games-roguelike/slashem/files/0.0.7E7/opengl.configure
new file mode 100644
index 000000000000..37466c28655c
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/opengl.configure
@@ -0,0 +1,10 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ define GL_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ define WINGLLIB
+END
+
diff --git a/games-roguelike/slashem/files/0.0.7E7/prepare-gui.configure b/games-roguelike/slashem/files/0.0.7E7/prepare-gui.configure
new file mode 100644
index 000000000000..803bd67a7354
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/prepare-gui.configure
@@ -0,0 +1,67 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ undefine X11_GRAPHICS
+ undefine QT_GRAPHICS
+ undefine GTK_GRAPHICS
+ undefine GNOME_GRAPHICS
+ undefine SDL_GRAPHICS
+ undefine GL_GRAPHICS
+ undefine PROXY_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ undefine WINX11SRC
+ undefine WINX11OBJ
+ undefine WINX11LIB
+
+ undefine WINQTSRC
+ undefine WINQTOBJ
+ undefine WINQTLIB
+
+ undefine WINGTKSRC
+ undefine WINGTKOBJ
+ undefine WINGTKLIB
+
+ undefine WINGNOMESRC
+ undefine WINGNOMEOBJ
+ undefine WINGNOMELIB
+
+ undefine WINPROXYSRC
+ undefine PROXYUTLSRC
+ undefine PROXYCOMSRC
+ undefine PROXYCLNTSRC
+
+ undefine WINPROXYOBJ
+ undefine PROXYUTLOBJ
+ undefine PROXYCOMOBJ
+ undefine PROXYCLNTOBJ
+
+ undefine WINPROXYLIB
+
+ undefine WINGLSRC
+ undefine WINGLOBJ
+ undefine WINGLLIB
+ undefine WINSDLLIB
+
+ undefine WINSRC
+ undefine WINOBJ
+ undefine WINLIB
+ define -C "to support all standard windowing systems" WINSRC
+ define -C "to support all standard windowing systems" WINOBJ
+ define -C "to support all standard windowing systems" WINLIB
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ undefine CNF_SHARE_QTND
+ undefine CNF_SHARE_X11ND
+ undefine CNF_SHARE_GTKND
+ undefine CNF_SHARE_GTKPROXYND
+ undefine CNF_SHARE_GLND
+ undefine CNF_SHARE_GNOMEND
+ undefine CNF_SHARE_PROXYND
+ redefine CNF_SHARE_DATND " \$(CNF_SHARE_QTND) \$(CNF_SHARE_X11ND) \\\
+ \$(CNF_SHARE_GTKND) \$(CNF_SHARE_GTKPROXYND) \$(CNF_SHARE_GLND) \\\
+ \$(CNF_SHARE_GNOMEND) \$(CNF_SHARE_PROXYND) "
+END
diff --git a/games-roguelike/slashem/files/0.0.7E7/proxy.slashemrc b/games-roguelike/slashem/files/0.0.7E7/proxy.slashemrc
new file mode 100644
index 000000000000..f28cdafb7b07
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/proxy.slashemrc
@@ -0,0 +1,4 @@
+TILESET=name:Small tiles, file:gltile16.png, transparent
+TILESET=name:Big tiles, file:gltile32.png, transparent
+TILESET=name:Big 3D tiles, file:gltile64.png, transparent, pseudo3D
+OPTIONS=tiles:Big 3D tiles
diff --git a/games-roguelike/slashem/files/0.0.7E7/qt.configure b/games-roguelike/slashem/files/0.0.7E7/qt.configure
new file mode 100644
index 000000000000..8e96c5004431
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/qt.configure
@@ -0,0 +1,23 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ define QT_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ define WINQTSRC
+ define WINQTOBJ
+ define WINQTLIB
+ define QTDIR
+ qtdir2=`echo /usr/lib/qt-2.*`
+ define QTDIR "${QTDIR:-$qtdir2}"
+ undefine CXXFLAGS
+ define CXXFLAGS
+ undefine LINK
+ define -C "Qt is C++" LINK
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ define CNF_SHARE_QTND
+END
diff --git a/games-roguelike/slashem/files/0.0.7E7/sdl.configure b/games-roguelike/slashem/files/0.0.7E7/sdl.configure
new file mode 100644
index 000000000000..f0c9e187ce14
--- /dev/null
+++ b/games-roguelike/slashem/files/0.0.7E7/sdl.configure
@@ -0,0 +1,16 @@
+configure config_h $toplevel/include/config.h
+BEGIN
+ define SDL_GRAPHICS
+END
+
+configure src_Makefile $toplevel/src/Makefile
+BEGIN
+ define WINGLSRC
+ define WINGLOBJ
+ define WINSDLLIB
+END
+
+configure Makefile $toplevel/Makefile
+BEGIN
+ define CNF_SHARE_GLND
+END