summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/to-the-moon')
-rw-r--r--games-rpg/to-the-moon/Manifest1
-rw-r--r--games-rpg/to-the-moon/metadata.xml8
-rw-r--r--games-rpg/to-the-moon/to-the-moon-0.ebuild97
3 files changed, 106 insertions, 0 deletions
diff --git a/games-rpg/to-the-moon/Manifest b/games-rpg/to-the-moon/Manifest
new file mode 100644
index 000000000000..3b426e80395b
--- /dev/null
+++ b/games-rpg/to-the-moon/Manifest
@@ -0,0 +1 @@
+DIST ToTheMoon_linux_1389114090.sh 75823678 SHA256 8272e4693dcf553f4285de4c46e89e1e2e4d5a59a088396b7ea188f935407970 SHA512 bed844f143ef9c3ff8fe93da186422e84d259229874c331315d8f1c7538fd6c417d6ca1aeecbe6c2a664fad98aff51f4723227d0ef07612acf29f86313f9aa1a WHIRLPOOL a3ebaed2e50636d2692ba1b893001cdb327c650d2b5336e928c6f6b74d3a382ed1c392b748e61d7037aa08f4029a524b5b83933f77da57177a9e1bc968385087
diff --git a/games-rpg/to-the-moon/metadata.xml b/games-rpg/to-the-moon/metadata.xml
new file mode 100644
index 000000000000..66b6e3dea3ef
--- /dev/null
+++ b/games-rpg/to-the-moon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>Use bundled libraries</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-rpg/to-the-moon/to-the-moon-0.ebuild b/games-rpg/to-the-moon/to-the-moon-0.ebuild
new file mode 100644
index 000000000000..f278190a77f8
--- /dev/null
+++ b/games-rpg/to-the-moon/to-the-moon-0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundling sdl-sound breaks the game
+
+EAPI=5
+
+inherit eutils unpacker gnome2-utils games
+
+MY_PN=ToTheMoon
+DESCRIPTION="Indie Adventure RPG, two doctors traversing the memories of a dying man to fulfill his last wish"
+HOMEPAGE="http://freebirdgames.com/games/to-the-moon"
+SRC_URI="${MY_PN}_linux_1389114090.sh"
+
+LICENSE="all-rights-reserved bundled-libs? ( LGPL-2 LGPL-2.1 ZLIB )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${MY_PN}.bin*"
+if [[ ${ARCH} == "amd64" ]] ; then
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib64/*"
+else
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+fi
+
+RDEPEND="
+ !bundled-libs? (
+ dev-libs/libsigc++:2
+ >=media-libs/libsdl2-2.0.1[X,joystick,opengl,sound,threads,video]
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-ttf
+ )
+ sys-libs/zlib
+ virtual/opengl"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_unpack() {
+ # mojo stuff inside makeself archive, unpack_makeself fails
+ local lastline=$(( $(grep -a -h -n -m 1 -F -e "Extra newline, because in very rare cases (OpenSolaris) stub is directly added after script" "${DISTDIR}/${A}" | cut -d':' -f1) + 1 ))
+ [[ ${lastline} ]] || die "no last line"
+ local offset=$(head -n ${lastline} "${DISTDIR}/${A}" | wc -c)
+ [[ ${offset} ]] || die "no offset"
+ dd ibs=${offset} skip=1 if="${DISTDIR}/${A}" of="${T}"/moon.zip || die
+ unpack_zip "${T}"/moon.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local libsuffix=$(usex amd64 "64" "")
+ local arch=$(usex amd64 "x86_64" "x86")
+
+ insinto "${dir}"
+ doins -r noarch/{Audio,Data,Fonts,Graphics,Game.ini,mkxp.conf,ToTheMoon.png}
+
+ exeinto "${dir}"
+ doexe ${arch}/${MY_PN}.bin.${arch}
+
+ exeinto "${dir}/lib${libsuffix}"
+ if use bundled-libs ; then
+ doexe ${arch}/lib${libsuffix}/*
+ else
+ doexe ${arch}/lib${libsuffix}/libSDL_sound-1.0.so.1
+ fi
+
+ games_make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
+ make_desktop_entry ${PN} "To the Moon"
+ newicon -s 32 noarch/${MY_PN}.png ${PN}.png
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}