summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/ut2003-ded')
-rw-r--r--games-server/ut2003-ded/Manifest2
-rw-r--r--games-server/ut2003-ded/metadata.xml8
-rw-r--r--games-server/ut2003-ded/ut2003-ded-2225-r2.ebuild72
3 files changed, 82 insertions, 0 deletions
diff --git a/games-server/ut2003-ded/Manifest b/games-server/ut2003-ded/Manifest
new file mode 100644
index 000000000000..f436c56c65ed
--- /dev/null
+++ b/games-server/ut2003-ded/Manifest
@@ -0,0 +1,2 @@
+DIST UT2003CrashFix.zip 2764 SHA256 df1a6fdf81f388486b20abf301ef86fb72b0b12d96bec789d7cb7103da579813 SHA512 24fdaac873b08a0860c23f66b9bd93922fc4f64486adbe9bfefeb340f9d9374778b5e7bacd0e12cc79d819fb340e007ab2a7f1f45c9e4f27ab3ab6b11033d444 WHIRLPOOL ddea25bf472d5ca7f9c9dca1346820045504c10be90e914cd0c000a04c48ad4765e4b283a35cd91c2cb9f4cd8e1d2cabac660c2bfeccff05ecc42b1379242ff5
+DIST ut2003-lnxded-2225.tar.bz2 304132056 SHA256 eb74193dd4bcedfb0b50da3853027c0098cd2ec8673d115fbf31d6e29e010013 SHA512 33ea560fe2583c2c82d0d1499e5ad16fcd70efdede27e088cb9e5a14cf6ce72f57fad8783e4b5a3fe2dbfc9277fc4d0094d6ad854a1a2150a9d04d967516fee4 WHIRLPOOL 9f2678ea68e728b1cd30f0cb3c90be1d6846e8ac9b00685ea2f9463306d5dd75a00924f9e48008f87cc9bbd39c8ef1cccd987e22d1aa7ad350ff1486423cd009
diff --git a/games-server/ut2003-ded/metadata.xml b/games-server/ut2003-ded/metadata.xml
new file mode 100644
index 000000000000..de0596352e80
--- /dev/null
+++ b/games-server/ut2003-ded/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Unreal Tounament 2003 is a first-person 3-D shooter and sequel to the 1999 Game of the Year, Unreal Tournament. The game was ported to Linux by Ryan "icculus" Gordon under contract from Epic Games and the Linux installer was released in the retail box. This is the dedicated server portion of the game and does not require the retail discs to use.
+</longdescription>
+</pkgmetadata>
diff --git a/games-server/ut2003-ded/ut2003-ded-2225-r2.ebuild b/games-server/ut2003-ded/ut2003-ded-2225-r2.ebuild
new file mode 100644
index 000000000000..3b7d774ca8ac
--- /dev/null
+++ b/games-server/ut2003-ded/ut2003-ded-2225-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Unreal Tournament 2003 Linux Dedicated Server"
+HOMEPAGE="http://www.ut2003.com/"
+SRC_URI="http://ftp.games.skynet.be/pub/misc/ut2003-lnxded-${PV}.tar.bz2
+ mirror://gentoo/UT2003CrashFix.zip"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror strip"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_PREBUILT="${dir:1}/System/*"
+
+src_unpack() {
+ unpack ut2003-lnxded-${PV}.tar.bz2
+ unzip "${DISTDIR}"/UT2003CrashFix.zip || die
+}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ dodir "${dir}"
+ mv "${S}"/ut2003_dedicated/* "${Ddir}"
+
+ # Here we apply DrSiN's crash patch
+ cp "${S}"/CrashFix/System/crashfix.u "${Ddir}"/System
+
+ ed "${Ddir}"/System/Default.ini >/dev/null 2>&1 <<EOT
+$
+?Engine.GameInfo?
+a
+AccessControlClass=crashfix.iaccesscontrolini
+.
+w
+q
+EOT
+
+ # Here we apply fix for bug #54726
+ sed -i \
+ -e "s:UplinkToGamespy=True:UplinkToGamespy=False:" \
+ "${D}${dir}"/System/Default.ini || die
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "NOTE: To have your server authenticate properly, you"
+ ewarn " MUST visit the following site and request a key."
+ ewarn "http://ut2003.epicgames.com/ut2003server/cdkey.php"
+ echo
+ ewarn "If you are not installing for the first time and you plan on running"
+ ewarn "a server, you will probably need to edit your"
+ ewarn "~/.ut2003/System/UT2003.ini file and add a line that says"
+ ewarn "AccessControlClass=crashfix.iaccesscontrolini to your"
+ ewarn "[Engine.GameInfo] section to close a security issue."
+}