summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/qct/qct-0.7-r1.ebuild')
-rw-r--r--games-simulation/qct/qct-0.7-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/games-simulation/qct/qct-0.7-r1.ebuild b/games-simulation/qct/qct-0.7-r1.ebuild
deleted file mode 100644
index 0875470b67bd..000000000000
--- a/games-simulation/qct/qct-0.7-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-inherit eutils python-single-r1 games
-
-DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
-HOMEPAGE="https://packages.gentoo.org/package/games-simulation/qct"
-SRC_URI="http://www.sourcefiles.org/Games/Role_Play/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND=">=dev-python/pygame-1.5.5[${PYTHON_USEDEP}]"
-RDEPEND=${RDEPEND}
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-constant.patch
- python_fix_shebang .
-}
-
-src_install() {
- # Ug. Someone fix this to install in $(games_get_libdir)/${PN} instead
- local destdir="${GAMES_DATADIR}/${PN}"
- insinto "${destdir}"
- exeinto "${destdir}"
-
- dodoc README
- doins *.py *.png
- doexe qct.py
-
- python_optimize "${D}${GAMES_DATADIR}/${PN}"
-
- games_make_wrapper qct "./qct.py" "${destdir}"
-
- prepgamesdirs
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
- games_pkg_setup
-}