summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/0ad')
-rw-r--r--games-strategy/0ad/0ad-0.0.20_alpha.ebuild151
-rw-r--r--games-strategy/0ad/Manifest1
-rw-r--r--games-strategy/0ad/files/0ad-0.0.20_alpha-gentoo.patch105
3 files changed, 0 insertions, 257 deletions
diff --git a/games-strategy/0ad/0ad-0.0.20_alpha.ebuild b/games-strategy/0ad/0ad-0.0.20_alpha.ebuild
deleted file mode 100644
index 5ccfab2942cb..000000000000
--- a/games-strategy/0ad/0ad-0.0.20_alpha.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-WX_GTK_VER="3.0"
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads,ssl"
-
-inherit eutils wxwidgets toolchain-funcs gnome2-utils python-any-r1 games
-
-MY_P=0ad-${PV/_/-}
-DESCRIPTION="A free, real-time strategy game"
-HOMEPAGE="https://play0ad.com/"
-SRC_URI="mirror://sourceforge/zero-ad/${MY_P}-unix-build.tar.xz"
-
-LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="editor +lobby nvtt pch sound test"
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/icu:=
- dev-libs/libxml2
- dev-libs/nspr
- ~games-strategy/0ad-data-${PV}
- media-libs/libpng:0
- media-libs/libsdl2[X,opengl,video]
- net-libs/enet:1.3
- net-libs/miniupnpc:=
- net-misc/curl
- sys-libs/zlib
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXcursor
- editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
- lobby? ( net-libs/gloox )
- nvtt? ( media-gfx/nvidia-texture-tools )
- sound? ( media-libs/libvorbis
- media-libs/openal )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- virtual/pkgconfig
- test? ( dev-lang/perl )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- games_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_configure() {
- local myconf=(
- --with-system-nvtt
- --with-system-miniupnpc
- --minimal-flags
- $(usex nvtt "" "--without-nvtt")
- $(usex pch "" "--without-pch")
- $(usex test "" "--without-tests")
- $(usex sound "" "--without-audio")
- $(usex editor "--atlas" "")
- $(usex lobby "" "--without-lobby")
- --collada
- --bindir="${GAMES_BINDIR}"
- --libdir="$(games_get_libdir)"/${PN}
- --datadir="${GAMES_DATADIR}"/${PN}
- )
-
- # stock premake4 does not work, use the shipped one
- emake -C "${S}"/build/premake/premake4/build/gmake.unix
-
- # regenerate scripts.c so our patch applies
- cd "${S}"/build/premake/premake4 || die
- "${S}"/build/premake/premake4/bin/release/premake4 embed || die
-
- # rebuild premake again... this is the most stupid build system
- emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
- emake -C "${S}"/build/premake/premake4/build/gmake.unix
-
- # run premake to create build scripts
- cd "${S}"/build/premake || die
- "${S}"/build/premake/premake4/bin/release/premake4 \
- --file="premake4.lua" \
- --outpath="../workspaces/gcc/" \
- --platform=$(usex amd64 "x64" "x32") \
- --os=linux \
- "${myconf[@]}" \
- gmake || die "Premake failed"
-}
-
-src_compile() {
- tc-export AR
-
- # build bundled and patched spidermonkey
- cd libraries/source/spidermonkey || die
- JOBS="${MAKEOPTS}" ./build.sh || die
- cd "${S}" || die
-
- # build 3rd party fcollada
- emake -C libraries/source/fcollada/src
-
- # build 0ad
- emake -C build/workspaces/gcc verbose=1
-}
-
-src_test() {
- cd binaries/system || die
- ./test -libdir "${S}/binaries/system" || die "test phase failed"
-}
-
-src_install() {
- newgamesbin binaries/system/pyrogenesis 0ad
- use editor && newgamesbin binaries/system/ActorEditor 0ad-ActorEditor
-
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r binaries/data/l10n
-
- exeinto "$(games_get_libdir)"/${PN}
- doexe binaries/system/libCollada.so
- doexe libraries/source/spidermonkey/lib/*.so
- use editor && doexe binaries/system/libAtlasUI.so
-
- dodoc binaries/system/readme.txt
- doicon -s 128 build/resources/${PN}.png
- make_desktop_entry ${PN}
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
index 616caf97e656..f0cbb7ea63cc 100644
--- a/games-strategy/0ad/Manifest
+++ b/games-strategy/0ad/Manifest
@@ -1,3 +1,2 @@
-DIST 0ad-0.0.20-alpha-unix-build.tar.xz 25610932 SHA256 a396d5cb37057ddd3cd523434f70c56be21588a2228443e7508d2b2d610fc68e SHA512 786f92b74c2e0c64c07ef2f5578dcb5c753fb4fed7238d385bca23549805fcfaeecb9bfbfae809a2ac09a7dfc804455237346588099db347c28a3ff0ae284c43 WHIRLPOOL 2d4b4e96dcb80e265cbbbddfe3b52e72110a419713f6644a68d2a9d499ffc57f03d5b68e612d00ccd889ec9a19609b968af450b228ef586d9567bd16cbc76fcb
DIST 0ad-0.0.21-alpha-unix-build.tar.xz 29196476 SHA256 96be23e4284a3931ef9536f988f2517040bde1f8700ee048bff18c932d8683cf SHA512 68f3586375f7dcbf3dfb6476040b8b43da8e2ea1e74947223ff5c9936b54a93caef919d8982d78c6f4ad01ee8f707b38a2c37cdab88ea5c5408544364cff4c37 WHIRLPOOL 8e72c2c3311169eabab5a8a028ffc90b8d6838f72d23ebbac3e5331a7f9434bbe7cae8cf0f5a97bf30b913f7f7f737d264aaf86298f8f65c81a270b0c4e5f871
DIST 0ad-0.0.22-alpha-unix-build.tar.xz 29199308 SHA256 fddd36df4fd32b5b31fd8871bc5ed3ec71a921de79517fb6199ba7571ec9f5b1 SHA512 3f917e77c6cc1d3fb585c98950db6eab3f5895ba3db41a8737f8172c769b5582689b436cab31eeafecce0e9639ee456afc7b78ebb03435b06512eb9fe7393771 WHIRLPOOL ae33f4f77cb981a0e8f00969c6b1ee05a2f06bacb70f79bfac74fda383bffedd4c6027370d5003e3d7815d5c68e13308b3553d8810bc69eebee143231968e95c
diff --git a/games-strategy/0ad/files/0ad-0.0.20_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.20_alpha-gentoo.patch
deleted file mode 100644
index 37a4ef9131dc..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.20_alpha-gentoo.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-diff -Naur 0ad-0.0.20-alpha.old/build/premake/premake4/build/gmake.unix/Premake4.make 0ad-0.0.20-alpha/build/premake/premake4/build/gmake.unix/Premake4.make
---- 0ad-0.0.20-alpha.old/build/premake/premake4/build/gmake.unix/Premake4.make 2016-04-01 20:13:10.176916471 +0200
-+++ 0ad-0.0.20-alpha/build/premake/premake4/build/gmake.unix/Premake4.make 2016-04-01 20:17:20.456909743 +0200
-@@ -26,12 +26,12 @@
- DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -Os
-- CXXFLAGS += $(CPPFLAGS) -Wall -Os
-- LDFLAGS += -s -rdynamic
-- LIBS += -lm -ldl
-- RESFLAGS += $(DEFINES) $(INCLUDES)
-- LDDEPS +=
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
-+ LDFLAGS += -rdynamic
-+ LIBS += -lm -ldl
-+ RESFLAGS += $(DEFINES) $(INCLUDES)
-+ LDDEPS +=
- LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(LDDEPS) $(LIBS)
- define PREBUILDCMDS
- endef
-@@ -48,12 +48,12 @@
- DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -g
-- CXXFLAGS += $(CPPFLAGS) -Wall -g
-+ CFLAGS += $(CFLAGS) $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CXXFLAGS) $(CPPFLAGS) -Wall
- LDFLAGS += -rdynamic
-- LIBS += -lm -ldl
-- RESFLAGS += $(DEFINES) $(INCLUDES)
-- LDDEPS +=
-+ LIBS += -lm -ldl
-+ RESFLAGS += $(DEFINES) $(INCLUDES)
-+ LDDEPS +=
- LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(LDDEPS) $(LIBS)
- define PREBUILDCMDS
- endef
-diff -Naur 0ad-0.0.20-alpha.old/build/premake/premake4/src/tools/gcc.lua 0ad-0.0.20-alpha/build/premake/premake4/src/tools/gcc.lua
---- 0ad-0.0.20-alpha.old/build/premake/premake4/src/tools/gcc.lua 2016-04-01 20:13:10.170916472 +0200
-+++ 0ad-0.0.20-alpha/build/premake/premake4/src/tools/gcc.lua 2016-04-01 20:15:21.051912953 +0200
-@@ -136,8 +136,6 @@
- if not cfg.flags.Symbols then
- if cfg.system == "macosx" then
- table.insert(result, "-Wl,-x")
-- else
-- table.insert(result, "-s")
- end
- end
-
-diff -Naur 0ad-0.0.20-alpha.old/libraries/source/fcollada/src/Makefile 0ad-0.0.20-alpha/libraries/source/fcollada/src/Makefile
---- 0ad-0.0.20-alpha.old/libraries/source/fcollada/src/Makefile 2016-04-01 20:13:10.197916471 +0200
-+++ 0ad-0.0.20-alpha/libraries/source/fcollada/src/Makefile 2016-04-01 20:14:17.511914661 +0200
-@@ -9,9 +9,9 @@
-
- CXX ?= g++
- CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
--CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
--CXXFLAGS_RELEASE := -O2 -DNDEBUG -DRETAIL
--CXXFLAGS_TEST := -O0 -g -D_DEBUG
-+CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
-+CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
-+CXXFLAGS_TEST := -D_DEBUG
- LIBS += `pkg-config libxml-2.0 --libs`
- INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
- INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
-diff -Naur 0ad-0.0.20-alpha.old/libraries/source/spidermonkey/build.sh 0ad-0.0.20-alpha/libraries/source/spidermonkey/build.sh
---- 0ad-0.0.20-alpha.old/libraries/source/spidermonkey/build.sh 2016-04-01 20:13:10.185916471 +0200
-+++ 0ad-0.0.20-alpha/libraries/source/spidermonkey/build.sh 2016-04-01 20:19:03.800906965 +0200
-@@ -79,20 +79,8 @@
- cd js/src
-
- # Clean up data generated by previous builds that could cause problems
--rm -rf build-debug
- rm -rf build-release
-
--# We want separate debug/release versions of the library, so we have to change
--# the LIBRARY_NAME for each build.
--# (We use perl instead of sed so that it works with MozillaBuild on Windows,
--# which has an ancient sed.)
--perl -i.bak -pe 's/(LIBRARY_NAME\s+=).*/$1 '\''mozjs31-ps-debug'\''/' moz.build
--mkdir -p build-debug
--cd build-debug
--CXXFLAGS="${TLCXXFLAGS}" ../configure ${CONF_OPTS} --with-nspr-libs="$NSPR_LIBS" --with-nspr-cflags="$NSPR_INCLUDES" --enable-debug --disable-optimize --enable-js-diagnostics --enable-gczeal # --enable-root-analysis
--${MAKE} ${MAKE_OPTS}
--cd ..
--
- perl -i.bak -pe 's/(LIBRARY_NAME\s+=).*/$1 '\''mozjs31-ps-release'\''/' moz.build
- mkdir -p build-release
- cd build-release
-@@ -134,12 +122,9 @@
- mkdir -p ${INCLUDE_DIR_DEBUG}
- mkdir -p ${INCLUDE_DIR_RELEASE}
- cp -R -L mozjs31/js/src/build-release/dist/include/* ${INCLUDE_DIR_RELEASE}/
--cp -R -L mozjs31/js/src/build-debug/dist/include/* ${INCLUDE_DIR_DEBUG}/
-
- mkdir -p lib/
--cp -L mozjs31/js/src/build-debug/dist/lib/${LIB_PREFIX}mozjs31-ps-debug${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs31-ps-debug${LIB_DST_SUFFIX}
- cp -L mozjs31/js/src/build-release/dist/lib/${LIB_PREFIX}mozjs31-ps-release${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs31-ps-release${LIB_DST_SUFFIX}
--cp -L mozjs31/js/src/build-debug/dist/bin/${LIB_PREFIX}mozjs31-ps-debug${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs31-ps-debug${DLL_DST_SUFFIX}
- cp -L mozjs31/js/src/build-release/dist/bin/${LIB_PREFIX}mozjs31-ps-release${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs31-ps-release${DLL_DST_SUFFIX}
-
- # Flag that it's already been built successfully so we can skip it next time