summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/darwinia')
-rw-r--r--games-strategy/darwinia/Manifest2
-rw-r--r--games-strategy/darwinia/darwinia-1.3.0.ebuild63
-rw-r--r--games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild65
-rw-r--r--games-strategy/darwinia/metadata.xml5
4 files changed, 135 insertions, 0 deletions
diff --git a/games-strategy/darwinia/Manifest b/games-strategy/darwinia/Manifest
new file mode 100644
index 000000000000..b460b9a8c8f2
--- /dev/null
+++ b/games-strategy/darwinia/Manifest
@@ -0,0 +1,2 @@
+DIST darwinia-full-1.3.0.sh 4010019 SHA256 847ecce5b5cee1a576531d0e1291f2e7838a69fd0a2ac426088d3b8944f11bbd SHA512 9790c1534a868b9561acf451cccb3356eb85ecbf8e271e344468b7982466802da5e3537c555839acfa64e1c56a25a08f8dba47a69eaf9de21a7575fba4dc2ebb WHIRLPOOL a6119243befc3b64487247373e43311da0e117aa212dea82f01dc144900e4346dc7c19fff078b0465833ccbffaf2f41a2e29386c34187b495e0314a49c434d81
+DIST darwinia-full-1.4.0b9.sh 4228121 SHA256 9355b4a3feb28c1399ee95a29fd089ed7cc34400a2ae0aaa4b34ea433887f00c SHA512 ed228943d4e70fc5799bbe7566b4fd862f2494f9d02bcd874f0d1b93d7bbc9a2c24a98fb5b8219fed20759bfe2af54d6ea33c60ddd8d8850e591a89822b41bb5 WHIRLPOOL a20dfc49be659ba4418cad4a5de7d287e5402aa56cdd6b8c801c1c2da83779acb51b7f31579d994afaf2ed3a4a956b8a6d7638224371e030917f02d941546fbb
diff --git a/games-strategy/darwinia/darwinia-1.3.0.ebuild b/games-strategy/darwinia/darwinia-1.3.0.ebuild
new file mode 100644
index 000000000000..2cfbe7a25cdd
--- /dev/null
+++ b/games-strategy/darwinia/darwinia-1.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CDROM_OPTIONAL="yes"
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="the hyped indie game of the year. By the Uplink creators"
+HOMEPAGE="http://www.darwinia.co.uk/support/linux.html"
+SRC_URI="http://www.introversion.co.uk/darwinia/downloads/${PN}-full-${PV}.sh"
+
+LICENSE="Introversion"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+RDEPEND="
+ ~virtual/libstdc++-3.3
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+src_unpack() {
+ use cdinstall && cdrom_get_cds gamefiles/main.dat
+ unpack_makeself
+}
+
+src_install() {
+ insinto "${dir}"/lib
+ exeinto "${dir}"/lib
+
+ doins lib/{language,patch}.dat
+ doexe lib/darwinia.bin.x86 lib/open-www.sh
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/darwinia
+
+ if use cdinstall ; then
+ doins "${CDROM_ROOT}"/gamefiles/{main,sounds}.dat
+ fi
+
+ dodoc README
+ newicon darwinian.png darwinia.png
+
+ games_make_wrapper darwinia ./darwinia "${dir}" "${dir}"
+ make_desktop_entry darwinia "Darwinia"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ if ! use cdinstall; then
+ ewarn "To play the game, you need to copy main.dat and sounds.dat"
+ ewarn "from gamefiles/ on the game CD to ${dir}/lib/."
+ fi
+ games_pkg_postinst
+}
diff --git a/games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild b/games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild
new file mode 100644
index 000000000000..f80aec69f12e
--- /dev/null
+++ b/games-strategy/darwinia/darwinia-1.4.0_beta9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CDROM_OPTIONAL="yes"
+inherit eutils unpacker cdrom games
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="the hyped indie game of the year. By the Uplink creators"
+HOMEPAGE="http://www.darwinia.co.uk/support/linux.html"
+SRC_URI="http://www.introversion.co.uk/darwinia/downloads/${PN}-full-${MY_PV}.sh"
+
+LICENSE="Introversion"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+RDEPEND="
+ ~virtual/libstdc++-3.3
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/lib/darwinia.bin.x86"
+
+src_unpack() {
+ use cdinstall && cdrom_get_cds gamefiles/main.dat
+ unpack_makeself
+}
+
+src_install() {
+ insinto "${dir}"/lib
+ exeinto "${dir}"/lib
+
+ doins lib/{language,patch}.dat
+ doexe lib/darwinia.bin.x86 lib/open-www.sh
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/darwinia
+
+ if use cdinstall ; then
+ doins "${CDROM_ROOT}"/gamefiles/{main,sounds}.dat
+ fi
+
+ dodoc README
+ newicon darwinian.png darwinia.png
+
+ games_make_wrapper darwinia ./darwinia "${dir}" "${dir}"
+ make_desktop_entry darwinia "Darwinia"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ if ! use cdinstall; then
+ ewarn "To play the game, you need to copy main.dat and sounds.dat"
+ ewarn "from gamefiles/ on the game CD to ${dir}/lib/."
+ fi
+ games_pkg_postinst
+}
diff --git a/games-strategy/darwinia/metadata.xml b/games-strategy/darwinia/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/darwinia/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>