summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch')
-rw-r--r--games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch b/games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch
new file mode 100644
index 000000000000..f7ccdba126bb
--- /dev/null
+++ b/games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch
@@ -0,0 +1,34 @@
+From 77bdc407d0760a529e40914d16248dce01fd4778 Mon Sep 17 00:00:00 2001
+From: O01eg <o01eg@yandex.ru>
+Date: Wed, 8 Nov 2017 16:07:57 +0300
+Subject: [PATCH] Fix #1843
+
+---
+ CMakeLists.txt | 2 +-
+ GG/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/CMakeLists.txt 2018-06-03 11:36:04.631832409 -0400
++++ b/CMakeLists.txt 2018-06-03 11:36:20.678821846 -0400
+@@ -484,7 +484,7 @@
+ ${Boost_INCLUDE_DIRS}
+ ${OPENGL_INCLUDE_DIR}
+ ${GLEW_INCLUDE_DIRS}
+- ${SDL_INCLUDE_DIRS}
++ ${SDL_INCLUDE_DIR}
+ ${OPENAL_INCLUDE_DIR}
+ ${OGG_INCLUDE_DIRS}
+ ${VORBIS_INCLUDE_DIRS}
+diff --git a/GG/CMakeLists.txt b/GG/CMakeLists.txt
+index 5d3c157362..c5bf3825d8 100644
+--- a/GG/CMakeLists.txt
++++ b/GG/CMakeLists.txt
+@@ -184,7 +184,7 @@ target_include_directories(GiGiSDL SYSTEM
+ ${Boost_INCLUDE_DIRS}
+ ${OPENGL_INCLUDE_DIR}
+ ${GLEW_INCLUDE_DIRS}
+- ${SDL_INCLUDE_DIRS}
++ ${SDL_INCLUDE_DIR}
+ )
+
+ target_link_libraries(GiGiSDL