summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/homm2-demo/homm2-demo-0.ebuild')
-rw-r--r--games-strategy/homm2-demo/homm2-demo-0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-strategy/homm2-demo/homm2-demo-0.ebuild b/games-strategy/homm2-demo/homm2-demo-0.ebuild
new file mode 100644
index 000000000000..d365cab5c09e
--- /dev/null
+++ b/games-strategy/homm2-demo/homm2-demo-0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Data files for HoMM II Demo version"
+HOMEPAGE="https://archive.org/details/HeroesofMightandMagicIITheSuccessionWars_1020"
+SRC_URI="https://archive.org/download/HeroesofMightandMagicIITheSuccessionWars_1020/h2demo.zip -> ${P}.zip"
+
+LICENSE="HoMM2-Demo"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="games-engines/fheroes2"
+RDEPEND="
+ ${DEPEND}
+ !games-strategy/homm2-gold-gog
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/fheroes2/data
+ doins DATA/*
+
+ insinto /usr/share/fheroes2/maps
+ doins MAPS/*
+}
+
+pkg_postinst() {
+ elog "Run the game using ${EPREFIX}/usr/bin/fheroes2"
+}