summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild')
-rw-r--r--games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild b/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild
new file mode 100644
index 000000000000..fa8a9754f2a6
--- /dev/null
+++ b/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games java-pkg-2
+
+DESCRIPTION="defeat the returning Titan horde in a series of epic ground battles"
+HOMEPAGE="http://www.puppygames.net/revenge-of-the-titans/"
+SRC_URI="amd64? ( http://downloads.puppygames.net/RevengeOfTheTitans-amd64.tar.gz -> ${P}-amd64.tar.gz )
+ x86? ( http://downloads.puppygames.net/RevengeOfTheTitans-i386.tar.gz -> ${P}-i386.tar.gz )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+ virtual/opengl"
+DEPEND=""
+
+RESTRICT="mirror bindist strip"
+
+S=${WORKDIR}/${PN//-}
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ games_pkg_setup
+}
+
+# nothing to do ... stubs for eclasses
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ doins *.jar
+
+ exeinto "${dir}"
+ doexe *.so revenge.sh
+
+ games_make_wrapper ${PN} ./revenge.sh "${dir}" "${dir}"
+ doicon revenge.png
+ make_desktop_entry ${PN} "Revenge of the Titans" revenge
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ java-pkg-2_pkg_preinst
+ games_pkg_preinst
+}