summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/scorched3d')
-rw-r--r--games-strategy/scorched3d/Manifest1
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-fixups.patch25
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-freetype.patch45
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-gcc43.patch22
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch20
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-odbc.patch16
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-win32.patch18
-rw-r--r--games-strategy/scorched3d/metadata.xml8
-rw-r--r--games-strategy/scorched3d/scorched3d-44.ebuild78
9 files changed, 233 insertions, 0 deletions
diff --git a/games-strategy/scorched3d/Manifest b/games-strategy/scorched3d/Manifest
new file mode 100644
index 000000000000..170c7f00279c
--- /dev/null
+++ b/games-strategy/scorched3d/Manifest
@@ -0,0 +1 @@
+DIST Scorched3D-44-src.tar.gz 41689613 SHA256 1c8320bb2210030be71dd713c214fbd32f7dd663ea82031383e6b3636f8a8dba SHA512 27341d12ef9db5b64c1051a8abe45cef8a957e26c2cd8928f64c071589052d2857fc6f8104772bb67d5d348aef14122a117d9e00d61e4d9f963f3b5bbe5859ca WHIRLPOOL 6b7c744702b86df856d8879454e7c9616e31dc3a9f539bd97c53cba4bea0e59f44e3c703f847f3cd505ba0e90386887f7134f9500421b3d58ba12a9cc1fdbc0e
diff --git a/games-strategy/scorched3d/files/scorched3d-44-fixups.patch b/games-strategy/scorched3d/files/scorched3d-44-fixups.patch
new file mode 100644
index 000000000000..47499d4cf307
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-fixups.patch
@@ -0,0 +1,25 @@
+--- scorched.orig/configure.ac
++++ scorched/configure.ac
+@@ -13,22 +13,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+
+-LDFLAGS="$LDFLAGS -L/usr/X11R6/lib -L/usr/X11R6"
+-CPPFLAGS="$CPPFLAGS -I/usr/X11R6/include -I/usr/X11R6"
+-
+-if test `uname` == Darwin; then
+-LDFLAGS="$LDFLAGS -lmx"
+-CPPFLAGS="$CPPFLAGS -DFFTW_USE_DOUBLE -D__DARWIN__ -D__MACOSX__"
+-else
+-LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-fi
+-
+-AC_CHECK_LIB(fridge, beer, echo "Hmm?!",[
+- echo "Warning: No beer found in fridge!";
+- echo "We highly suggest that you rectify this situation immediately."
+-])
+-
+ AC_ARG_ENABLE(serveronly,
+ [ --enable-serveronly Enable server only compilation],
+ , enable_serveronly=no,
diff --git a/games-strategy/scorched3d/files/scorched3d-44-freetype.patch b/games-strategy/scorched3d/files/scorched3d-44-freetype.patch
new file mode 100644
index 000000000000..93c8ca358b31
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-freetype.patch
@@ -0,0 +1,45 @@
+--- acinclude.m4.orig
++++ acinclude.m4
+@@ -437,7 +437,7 @@
+ if test "$FT2_CONFIG" = "no" ; then
+ no_ft=yes
+ else
+- FT2_CFLAGS=`$FT2_CONFIG $ft_config_args --cflags`
++ FT2_CFLAGS="`$FT2_CONFIG $ft_config_args --cflags` `$FT2_CONFIG $ft_config_args --cflags | sed -e 's:freetype2:freetype2/freetype:'`"
+ FT2_LIBS=`$FT2_CONFIG $ft_config_args --libs`
+ ft_config_major_version=`$FT2_CONFIG $ft_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+--- src.orig/client/GLEXT/GLFont2dFreeType.h
++++ src/client/GLEXT/GLFont2dFreeType.h
+@@ -23,10 +23,10 @@
+
+ #include <GLEXT/GLFont2dStorage.h>
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include <freetype.h>
++#include <ftglyph.h>
++#include <ftoutln.h>
++#include <fttrigon.h>
+ #include <string>
+
+ class GLFont2dFreeType
+--- src.orig/launcher/wxdialogs/TrueTypeFont.h
++++ src/launcher/wxdialogs/TrueTypeFont.h
+@@ -25,10 +25,10 @@
+ #include <wx/image.h>
+ #include <ft2build.h>
+ #include <string>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include <freetype.h>
++#include <ftglyph.h>
++#include <ftoutln.h>
++#include <fttrigon.h>
+
+ class TrueTypeFont
+ {
diff --git a/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch b/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch
new file mode 100644
index 000000000000..79f40b70e652
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch
@@ -0,0 +1,22 @@
+--- scorched.old/src/common/common/main.h
++++ scorched/src/common/common/main.h
+@@ -40,7 +40,7 @@
+ void _no_storage()
+ {
+ printf("Failed to allocate memory!!");
+- std::exit(1);
++ exit(1);
+ }
+
+ void run_main(int argc, char *argv[], OptionsParameters &params)
+--- scorched.old/src/common/porting/windows.h
++++ scorched/src/common/porting/windows.h
+@@ -20,7 +20,7 @@
+ typedef unsigned short WORD;
+ typedef unsigned char BYTE;
+
+-typedef int HWND;
++// typedef int HWND;
+ typedef void * HINSTANCE;
+ typedef int WPARAM;
+ typedef int LPARAM;
diff --git a/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch b/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch
new file mode 100644
index 000000000000..8255dd33f5d3
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch
@@ -0,0 +1,20 @@
+--- src/common/image/ImageJpgFactory.cpp.old 2014-12-03 09:52:03.306552513 +0100
++++ src/common/image/ImageJpgFactory.cpp 2014-12-03 09:53:22.117786304 +0100
+@@ -79,7 +79,7 @@
+ src->next_input_byte = FakeEOI;
+ src->bytes_in_buffer = 2;
+
+- return TRUE;
++ return (boolean)TRUE;
+ }
+
+ METHODDEF(void)
+@@ -166,7 +166,7 @@
+ src->bytes_in_buffer = buffer.getBufferUsed();
+ src->next_input_byte = (JOCTET *) buffer.getBuffer();
+
+- jpeg_read_header(&cinfo, TRUE);
++ jpeg_read_header(&cinfo, (boolean)TRUE);
+ jpeg_start_decompress(&cinfo);
+
+ if ((cinfo.output_components == 3 && !readalpha) ||
diff --git a/games-strategy/scorched3d/files/scorched3d-44-odbc.patch b/games-strategy/scorched3d/files/scorched3d-44-odbc.patch
new file mode 100644
index 000000000000..e7f3833bf897
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-odbc.patch
@@ -0,0 +1,16 @@
+When x11-libs/wxGTK is built with the odbc use flag, scorched3d fails to build.
+bug #285384 - patch from Bob Johnson
+
+--- scorched/src/common/porting/windows.h
++++ fix_scorched/src/common/porting/windows.h
+@@ -11,8 +11,8 @@
+
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+-typedef unsigned int DWORD;
+-typedef unsigned int * LPDWORD;
++typedef unsigned long DWORD;
++typedef DWORD * LPDWORD;
+ typedef unsigned char * LPBYTE;
+ typedef int INT;
+ typedef long LONG;
diff --git a/games-strategy/scorched3d/files/scorched3d-44-win32.patch b/games-strategy/scorched3d/files/scorched3d-44-win32.patch
new file mode 100644
index 000000000000..05f9c806b1c7
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-44-win32.patch
@@ -0,0 +1,18 @@
+--- scorched.old/src/common/porting/windows.h
++++ scorched/src/common/porting/windows.h
+@@ -9,6 +9,7 @@
+ #include <ctype.h>
+ #include <common/Defines.h>
+
++#ifdef _WIN32
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+ typedef unsigned int DWORD;
+@@ -27,6 +28,7 @@
+ typedef int LRESULT;
+ typedef void * HDC;
+ typedef void * HGLRC;
++#endif /* _WIN32 */
+
+ #define _strnicmp(a,b,c) strncasecmp(a,b,c)
+ #define stricmp(a,b) strcasecmp(a,b)
diff --git a/games-strategy/scorched3d/metadata.xml b/games-strategy/scorched3d/metadata.xml
new file mode 100644
index 000000000000..339e10439c73
--- /dev/null
+++ b/games-strategy/scorched3d/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">scorched3d</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/scorched3d/scorched3d-44.ebuild b/games-strategy/scorched3d/scorched3d-44.ebuild
new file mode 100644
index 000000000000..19078cd23b43
--- /dev/null
+++ b/games-strategy/scorched3d/scorched3d-44.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=2.8
+inherit autotools eutils wxwidgets games
+
+DESCRIPTION="Multi-player tank battle in 3D (OpenGL)"
+HOMEPAGE="http://www.scorched3d.co.uk/"
+SRC_URI="mirror://sourceforge/scorched3d/Scorched3D-${PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="dedicated mysql"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-net
+ media-libs/libpng:0
+ sys-libs/zlib
+ virtual/jpeg:0
+ dev-libs/expat
+ media-fonts/dejavu
+ !dedicated? (
+ virtual/opengl
+ virtual/glu
+ media-libs/glew
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/freealut
+ x11-libs/wxGTK:2.8[X]
+ media-libs/freetype:2
+ sci-libs/fftw:3.0
+ )
+ mysql? ( virtual/mysql )"
+DEPEND="${RDEPEND}
+ !dedicated? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/scorched
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fixups.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-odbc.patch \
+ "${FILESDIR}"/${P}-win32.patch \
+ "${FILESDIR}"/${P}-freetype.patch \
+ "${FILESDIR}"/${P}-jpeg9.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-fftw=/usr \
+ --with-ogg=/usr \
+ --with-vorbis=/usr \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-wx-config="${WX_CONFIG}" \
+ --without-pgsql \
+ $(use_with mysql) \
+ $(use_enable dedicated serveronly)
+}
+
+src_install() {
+ default
+ rm "${ED}${GAMES_DATADIR}"/${PN}/data/fonts/* || die
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/${PN}/data/fonts/dejavusans.ttf"
+ dosym /usr/share/fonts/dejavu/DejaVuSansCondensed-Bold.ttf "${GAMES_DATADIR}/${PN}/data/fonts/dejavusconbd.ttf"
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${GAMES_DATADIR}/${PN}/data/fonts/dejavusmobd.ttf"
+ if ! use dedicated ; then
+ newicon data/images/tank-old.bmp ${PN}.bmp || die
+ make_desktop_entry ${PN} "Scorched 3D" /usr/share/pixmaps/${PN}.bmp
+ fi
+ prepgamesdirs
+}