summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/Manifest2
-rw-r--r--games-strategy/widelands/files/widelands-1.1-gcc-13.patch124
-rw-r--r--games-strategy/widelands/widelands-1.2.ebuild (renamed from games-strategy/widelands/widelands-1.1.ebuild)17
-rw-r--r--games-strategy/widelands/widelands-9999.ebuild13
4 files changed, 17 insertions, 139 deletions
diff --git a/games-strategy/widelands/Manifest b/games-strategy/widelands/Manifest
index 0a4c8d53cb7d..586eed9ef89a 100644
--- a/games-strategy/widelands/Manifest
+++ b/games-strategy/widelands/Manifest
@@ -1 +1 @@
-DIST widelands-1.1.tar.gz 416104611 BLAKE2B e217ff5a4e3ba0431b96290dd4908d7ddadaf1850e890cee135a54f88162b30d75dbf5bc5f086d6c5e8c5e4410a0a788201117c3615e15a3e2acfd00e8f01272 SHA512 29dbeae0940468c8aad6f0fa610c8467bdb6ecf2ba5fe9175683b7cdaab5f977fa86beb71de29057c829e9738568d15e10bc22fa7fc9e58132151a1a02d72d9d
+DIST widelands-1.2.tar.gz 457713595 BLAKE2B b89caef369268b31fb70c4b054f1df3651e974763c6b2d82488a662a7edaed19f525177371592f9ad28cc14194044d48862e22b38a3a449c6e7ed0023bf30d09 SHA512 e05812f93defe8b9a3da60e6ba73a65bba47abec3199298f9a778fb42655aba671cb45a2603c2936538de1e0f82892a183ea5e1df15937b9812d369d068fab81
diff --git a/games-strategy/widelands/files/widelands-1.1-gcc-13.patch b/games-strategy/widelands/files/widelands-1.1-gcc-13.patch
deleted file mode 100644
index c2f2501dff0d..000000000000
--- a/games-strategy/widelands/files/widelands-1.1-gcc-13.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-https://github.com/widelands/widelands/pull/5765
-
-From 14b9c357073126d11d719fd1a539bb7ef0154791 Mon Sep 17 00:00:00 2001
-From: Heiko Becker <heirecka@exherbo.org>
-Date: Wed, 25 Jan 2023 23:42:42 +0100
-Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
-
-Like other versions before, gcc 13 moved some includes around and as a
-result <cstdint> is no longer transitively included. Explicitly include
-it for uint16_t.
---- a/src/base/md5.h
-+++ b/src/base/md5.h
-@@ -21,6 +21,7 @@
- #define WL_BASE_MD5_H
-
- #include <cassert>
-+#include <cstdint>
- #include <cstring>
- #include <string>
-
---- a/src/base/random.h
-+++ b/src/base/random.h
-@@ -20,6 +20,7 @@
- #define WL_BASE_RANDOM_H
-
- #include <cassert>
-+#include <cstdint>
- #include <string>
-
- extern const uint32_t rng_sbox[256];
---- a/src/base/time_string.h
-+++ b/src/base/time_string.h
-@@ -19,6 +19,7 @@
- #ifndef WL_BASE_TIME_STRING_H
- #define WL_BASE_TIME_STRING_H
-
-+#include <cstdint>
- #include <string>
-
- /// Get a string representation conforming to ISO 8601 of the current time (in
---- a/src/build_info.h
-+++ b/src/build_info.h
-@@ -19,6 +19,7 @@
- #ifndef WL_BUILD_INFO_H
- #define WL_BUILD_INFO_H
-
-+#include <cstdint>
- #include <string>
-
- constexpr uint16_t kWidelandsCopyrightStart = 2002;
---- a/src/graphic/align.h
-+++ b/src/graphic/align.h
-@@ -19,6 +19,7 @@
- #ifndef WL_GRAPHIC_ALIGN_H
- #define WL_GRAPHIC_ALIGN_H
-
-+#include <cstdint>
- #include <string>
-
- #include "base/rect.h"
---- a/src/graphic/text/textstream.h
-+++ b/src/graphic/text/textstream.h
-@@ -19,6 +19,7 @@
- #ifndef WL_GRAPHIC_TEXT_TEXTSTREAM_H
- #define WL_GRAPHIC_TEXT_TEXTSTREAM_H
-
-+#include <cstdint>
- #include <string>
-
- namespace RT {
---- a/src/logic/generic_save_handler.h
-+++ b/src/logic/generic_save_handler.h
-@@ -19,6 +19,7 @@
- #ifndef WL_LOGIC_GENERIC_SAVE_HANDLER_H
- #define WL_LOGIC_GENERIC_SAVE_HANDLER_H
-
-+#include <cstdint>
- #include <functional>
-
- #include "io/filesystem/filesystem.h"
---- a/src/logic/map_revision.h
-+++ b/src/logic/map_revision.h
-@@ -19,6 +19,7 @@
- #ifndef WL_LOGIC_MAP_REVISION_H
- #define WL_LOGIC_MAP_REVISION_H
-
-+#include <cstdint>
- #include <string>
-
- namespace Widelands {
---- a/src/logic/save_handler.h
-+++ b/src/logic/save_handler.h
-@@ -19,6 +19,8 @@
- #ifndef WL_LOGIC_SAVE_HANDLER_H
- #define WL_LOGIC_SAVE_HANDLER_H
-
-+#include <cstdint>
-+
- #include "io/filesystem/filesystem.h"
-
- namespace Widelands {
---- a/src/map_io/map_elemental_packet.h
-+++ b/src/map_io/map_elemental_packet.h
-@@ -19,6 +19,7 @@
- #ifndef WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
- #define WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
-
-+#include <cstdint>
- #include <string>
- #include <vector>
-
---- a/src/scripting/persistence.h
-+++ b/src/scripting/persistence.h
-@@ -19,6 +19,8 @@
- #ifndef WL_SCRIPTING_PERSISTENCE_H
- #define WL_SCRIPTING_PERSISTENCE_H
-
-+#include <cstdint>
-+
- #include "scripting/lua.h"
-
- class FileRead;
---
-2.39.1
diff --git a/games-strategy/widelands/widelands-1.1.ebuild b/games-strategy/widelands/widelands-1.2.ebuild
index 4d2e256576f8..a573f92451d1 100644
--- a/games-strategy/widelands/widelands-1.1.ebuild
+++ b/games-strategy/widelands/widelands-1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -32,17 +32,16 @@ RDEPEND="
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-ttf
sys-libs/zlib:=[minizip]
- virtual/libintl"
+ virtual/libintl
+"
DEPEND="
${RDEPEND}
- dev-cpp/asio"
+ dev-cpp/asio
+"
BDEPEND="
${PYTHON_DEPS}
- sys-devel/gettext"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1-gcc-13.patch
-)
+ sys-devel/gettext
+"
src_configure() {
CMAKE_BUILD_TYPE=Release # disables -Werror
diff --git a/games-strategy/widelands/widelands-9999.ebuild b/games-strategy/widelands/widelands-9999.ebuild
index 694f1e6b01d3..a573f92451d1 100644
--- a/games-strategy/widelands/widelands-9999.ebuild
+++ b/games-strategy/widelands/widelands-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -32,13 +32,16 @@ RDEPEND="
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-ttf
sys-libs/zlib:=[minizip]
- virtual/libintl"
+ virtual/libintl
+"
DEPEND="
${RDEPEND}
- dev-cpp/asio"
+ dev-cpp/asio
+"
BDEPEND="
${PYTHON_DEPS}
- sys-devel/gettext"
+ sys-devel/gettext
+"
src_configure() {
CMAKE_BUILD_TYPE=Release # disables -Werror