summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/nml/nml-0.5.2.ebuild')
-rw-r--r--games-util/nml/nml-0.5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.5.2.ebuild b/games-util/nml/nml-0.5.2.ebuild
new file mode 100644
index 000000000000..e7fcb7a0ff99
--- /dev/null
+++ b/games-util/nml/nml-0.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into GRF/NFO files"
+HOMEPAGE="https://github.com/OpenTTD/nml"
+SRC_URI="https://github.com/OpenTTD/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( "README.md" "docs/changelog.txt" )
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/nmlc.1
+}