summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/umodpack/umodpack-0.5_beta16-r2.ebuild')
-rw-r--r--games-util/umodpack/umodpack-0.5_beta16-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
new file mode 100644
index 000000000000..117e06b1a253
--- /dev/null
+++ b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module toolchain-funcs
+
+MY_P=${P/_beta/b}
+DESCRIPTION="portable and useful [un]packer for Unreal Tournament's Umod files"
+HOMEPAGE="http://www.oldunreal.com/wiki/index.php?title=UmodPack"
+SRC_URI="mirror://gentoo/${MY_P}-allinone.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="tk"
+
+DEPEND="virtual/perl-IO-Compress
+ dev-perl/Archive-Zip
+ dev-perl/Tie-IxHash
+ tk? ( dev-perl/perl-tk )"
+
+S=${WORKDIR}/${MY_P}
+SRC_TEST="do parallel"
+
+src_prepare() {
+ # remove the stupid perl modules since we already installed em
+ rm -rf {Archive-Zip,Compress-Zlib,Tie-IxHash,Tk}* || die
+}
+
+src_compile() {
+ perl-module_src_compile
+
+ cd umr-0.3 || die
+ emake DEBUG=0 CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ mydoc="Changes"
+ perl-module_src_install
+ dobin umod umr-0.3/umr
+ if use tk ; then
+ dobin xumod
+ fi
+}