summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/xboxdrv')
-rw-r--r--games-util/xboxdrv/Manifest1
-rw-r--r--games-util/xboxdrv/files/github-144.patch15
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch16
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch13
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8.ebuild63
5 files changed, 0 insertions, 108 deletions
diff --git a/games-util/xboxdrv/Manifest b/games-util/xboxdrv/Manifest
index a08c71162940..22664cac47a9 100644
--- a/games-util/xboxdrv/Manifest
+++ b/games-util/xboxdrv/Manifest
@@ -1,2 +1 @@
DIST xboxdrv-0.8.8_p20190116.tar.gz 322469 BLAKE2B 8827cafb98235f7ad9d83204c808eb6bc25fdfd48321050ab79b561fc6a1a3b628e4bd667f7f1be511420514ef7906efc803db4f50130c393d7fa3cb498fed26 SHA512 3f9f8346a5a8486fb9f1af3e27a947e37c73ceab8f433639adf890144844f4fb6d005da3c4c6c1abf0a1550b71aba8b89001f58965d67fdc21e5f41e50a21436
-DIST xboxdrv-linux-0.8.8.tar.bz2 267919 BLAKE2B b6f09fc929ba561f0c18a777ca94f6972f366d29709d5fdcb168988311ca53eb813761df0f87d148795aa14d2d89b200e8123502c0b255ebe20e5f9caa18f8f1 SHA512 2978b33d23636431ee0cc393ea32d3d26ebe9f2b914f0bf8bc0e096f98202726768142e653bc5765ac55084b105ff3a6214bdf6e745fdd8aa167260c54c10494
diff --git a/games-util/xboxdrv/files/github-144.patch b/games-util/xboxdrv/files/github-144.patch
deleted file mode 100644
index 5782e1a8cd52..000000000000
--- a/games-util/xboxdrv/files/github-144.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Naur xboxdrv-linux-0.8.5.orig/src/usb_gsource.cpp xboxdrv-linux-0.8.5/src/usb_gsource.cpp
---- xboxdrv-linux-0.8.5.orig/src/usb_gsource.cpp 2013-04-07 18:27:49.000000000 +0100
-+++ xboxdrv-linux-0.8.5/src/usb_gsource.cpp 2016-07-02 12:35:41.692355904 +0100
-@@ -174,7 +174,10 @@
- gboolean
- USBGSource::on_source()
- {
-- libusb_handle_events(NULL);
-+ struct timeval to;
-+ to.tv_sec = 0;
-+ to.tv_usec = 0;
-+ libusb_handle_events_timeout_completed(NULL, &to, NULL);
- return TRUE;
- }
-
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch
deleted file mode 100644
index 80a8d8f550e1..000000000000
--- a/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Cast boost::shared_ptr explicitly for C++14.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=594674
-
---- a/src/controller_slot.cpp
-+++ b/src/controller_slot.cpp
-@@ -67,9 +67,9 @@ ControllerSlot::disconnect()
- }
-
- bool
- ControllerSlot::is_connected() const
- {
-- return m_thread;
-+ return static_cast<bool>(m_thread);
- }
-
- /* EOF */
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch
deleted file mode 100644
index d6df8d99e32e..000000000000
--- a/games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://dev.gentoo.org/~vapier/scons-blows.txt
-
-diff -Naur xboxdrv-linux-0.8.8.orig/SConstruct xboxdrv-linux-0.8.8/SConstruct
---- xboxdrv-linux-0.8.8.orig/SConstruct 2015-11-09 10:19:35.000000000 +0000
-+++ xboxdrv-linux-0.8.8/SConstruct 2016-07-02 16:13:52.560961836 +0100
-@@ -84,6 +84,7 @@
- opts.Add('CXXFLAGS', 'C++ Compiler flags')
- opts.Add('LINKFLAGS', 'Linker Compiler flags')
- opts.Add('AR', 'Library archiver')
-+opts.Add('RANLIB', 'Archive indexer')
- opts.Add('CC', 'C Compiler')
- opts.Add('CXX', 'C++ Compiler')
- opts.Add('BUILD', 'Build type: release, custom, development')
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
deleted file mode 100644
index a9324ad2dffe..000000000000
--- a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit linux-info scons-utils toolchain-funcs systemd udev
-
-MY_P=${PN}-linux-${PV}
-DESCRIPTION="Userspace Xbox 360 Controller driver"
-HOMEPAGE="https://pingus.seul.org/~grumbel/xboxdrv/"
-SRC_URI="https://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-libs/boost:=
- dev-libs/dbus-glib:=
- virtual/libudev:=
- sys-apps/dbus:=
- dev-libs/glib:2=
- virtual/libusb:1=
- x11-libs/libX11:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-scons.patch
- "${FILESDIR}"/github-144.patch
- "${FILESDIR}"/${P}-fix-c++14.patch
-)
-
-CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
-
-src_compile() {
- escons \
- BUILD=custom \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- CXXFLAGS="-Wall ${CXXFLAGS}" \
- LINKFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin xboxdrv
- doman doc/xboxdrv.1
- dodoc AUTHORS NEWS PROTOCOL README.md TODO
-
- newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
- newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv
-
- insinto /etc/dbus-1/system.d/
- doins "${FILESDIR}/org.seul.Xboxdrv.conf"
-
- udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
- systemd_dounit "${FILESDIR}"/xboxdrv.service
-}
-
-pkg_postinst() {
- udev_reload
-}