summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xpadneo/Manifest1
-rw-r--r--games-util/xpadneo/xpadneo-0.9.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
index 4cb0f0f85a80..49e09598d889 100644
--- a/games-util/xpadneo/Manifest
+++ b/games-util/xpadneo/Manifest
@@ -1 +1,2 @@
+DIST xpadneo-0.9.1.tar.gz 1353080 BLAKE2B fc2207e005cae629da50048330cbaa7d27183b0bbb083d35c3c144e91470273b8c7006c4b62d10b947dbe4fd003ca39623630923e477aa4eff3c243405d876bd SHA512 51063d104f165018b8430e26d2ab5a622c214efaaba3f7706cc99892b2054f57667b419672de5c2696189d389401b07024658c36a88343d980de9802789bcb10
DIST xpadneo-0.9.tar.gz 1351003 BLAKE2B dd41e687a44415c9c44d70ae4df9c858a7218eca301e61421cee4b9e80d912f9336dad15636dc38cb79128a635e33bb2b795fadebe2f53ebe42d192212364cb0 SHA512 0819af24bfa556dd330abeb1180b0a46105428b6b2c8529bb357cd5b578fe6f21e057f3f457994b21b6d5d6b207d46bdf0ff80a6415f833396595ba5e7309389
diff --git a/games-util/xpadneo/xpadneo-0.9.1.ebuild b/games-util/xpadneo/xpadneo-0.9.1.ebuild
new file mode 100644
index 000000000000..75edf29d3954
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-0.9.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs udev
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
+ EGIT_MIN_CLONE_TYPE="single"
+else
+ SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+S+="/hid-${PN}"
+MODULE_NAMES="hid-${PN}(kernel/drivers/hid::src)"
+BUILD_PARAMS='V=1 LD="$(tc-getLD)" KERNEL_SOURCE_DIR="${KV_OUT_DIR}"'
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /etc/modprobe.d
+ doins etc-modprobe.d/${PN}.conf
+
+ udev_dorules etc-udev-rules.d/60-${PN}.rules
+
+ dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ local ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}"
+ elog
+ elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
+ elog "cause the gamepad to enter a re-connection loop."
+ elog "- To disable immediately:"
+ elog " echo Y > ${ertm}"
+ elog "- To disable for next and subsequent boot:"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
+ elog " bluetooth.disable_ertm=y"
+ fi
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+}