summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/joystick/Manifest1
-rw-r--r--games-util/joystick/joystick-1.7.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
index b149747af8aa..6787593abc58 100644
--- a/games-util/joystick/Manifest
+++ b/games-util/joystick/Manifest
@@ -1,2 +1,3 @@
DIST linuxconsoletools-1.6.1.tar.bz2 50854 BLAKE2B 0614e72226c575499ae5976011a0fca146a1981e2d355f7554f105b184bdd4f1090bf5374377e89f3881c5476e3c3a362b70f86cfd83440264066ea50a8c6a4b SHA512 b520c0a2d55986204619e3a5a00fb8b1e26453ac6df4f51c8c87495661a68bb6fe5a1947a3e079a53a537bf06d23c73c404a4d7e4d4dd18c0f7f69c1985a77be
DIST linuxconsoletools-1.7.0.tar.bz2 52960 BLAKE2B 438e69e7aa220ea3fc92a9a72bda081c7877663c451f3101bc30e344a7a0f0f20b1c2f4ecd78c0db501b6442e2cd20e9f288c9c331118e8c666a61c3ac4b6851 SHA512 260667e167281dd6f4de0904c2852a5bf3d9d0fe9d603135d4849c5a6610997306c9b476f64e4015d17a4dc8e4a8d36e96e01b9b63664fc7b493201fe12b4f56
+DIST linuxconsoletools-1.7.1.tar.bz2 53153 BLAKE2B e05d04454fefdd4009d0c75f1caf2e6675a8e5f494f6f2f491f4de3c57101a6323b4de5795fccb9fd6a557a1e7bf4befa312661b022ed0503da83ac4dd3ab7c5 SHA512 2ba97e6c5b57aa5d6b08369bae050256f4d039f5b8479ad03cef4a7c43bf772db312de54d9e70a8a92c9ed7933b524715f1ce5448ccf508e6ffe8646a9dbd349
diff --git a/games-util/joystick/joystick-1.7.1.ebuild b/games-util/joystick/joystick-1.7.1.ebuild
new file mode 100644
index 000000000000..2f1e8014e508
--- /dev/null
+++ b/games-util/joystick/joystick-1.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+
+DESCRIPTION="Joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl2[video] )"
+RDEPEND="
+ ${DEPEND}
+ udev? ( virtual/udev )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+)
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+ export PREFIX="${EPREFIX}"/usr
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+
+ if ! use udev; then
+ rm "${ED}"/usr/bin/jscal-{re,}store || die
+ fi
+
+ if [[ ${EPREFIX} ]]; then
+ mv {"${D}","${ED}"}/lib || die
+ fi
+}