summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/cartridges/Manifest1
-rw-r--r--games-util/cartridges/cartridges-2.7.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/games-util/cartridges/Manifest b/games-util/cartridges/Manifest
index 4b8a7b054104..2a4cca359b3a 100644
--- a/games-util/cartridges/Manifest
+++ b/games-util/cartridges/Manifest
@@ -1,2 +1,3 @@
DIST cartridges-2.7.2.tar.gz 1094408 BLAKE2B 462c4117e0cc3050b9deac508704e863dab0f389e825007392a51a44fffb9eb9a98d8f915379b1eb7ecb696ed85a9027a3705835038109d814e96282a865883f SHA512 3dc9118034d8e5491c10b12515e099a05505da97aa19658509e6e36c6de1da5b34998973dfc5ea010c754eff5e44ce2603ed65037a213af4ed3db9107ddaa83c
DIST cartridges-2.7.3.tar.gz 1097578 BLAKE2B 71ac72127d1034a9f4eb64250f3595d4ff5efa4e4f062e7bd0847e2e8a513dcdbe827c3bae93db875c8467beeb2012363654e54fe4ba62987b48578ba3c420dd SHA512 67f9f9b4f4b396c57e989a0649f8261eed14729ad6bbc7d20557abe7d7c6e64ea7ef2cdcc80ef1aa6fe71b0bce34f91ed56e51595cbf9f14697aa439ea6ad601
+DIST cartridges-2.7.4.tar.gz 1099412 BLAKE2B 0f15bbe53d8a893dd22b54b0b9435e8a301536c3654b99a302622655dc1207dc657ec21f9c0b8bb7526465126e62d86f7b35ce5561ccf0c275282ce04b685a44 SHA512 3f0c8b7fb83454296d5d676a5a69a8e6c9ae0e833a092b43a45fe0ff39c9eeeb0593a8ae8cf6bf936f84fa2ed8141d8c35fc26a4a05d4eb9ab04e04c627ae4e9
diff --git a/games-util/cartridges/cartridges-2.7.4.ebuild b/games-util/cartridges/cartridges-2.7.4.ebuild
new file mode 100644
index 000000000000..bda78a7b129c
--- /dev/null
+++ b/games-util/cartridges/cartridges-2.7.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2-utils python-single-r1 meson xdg
+
+DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
+HOMEPAGE="https://github.com/kra-mo/cartridges/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
+else
+ SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Just appstream file validation that uses network.
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=gui-libs/libadwaita-1.4.0:1[introspection]
+ gui-libs/gtk:4[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+src_install() {
+ meson_src_install
+
+ python_fix_shebang "${ED}/usr/bin"
+ python_optimize "${ED}/usr"
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}