summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgtop/libgtop-2.38.0.ebuild')
-rw-r--r--gnome-base/libgtop/libgtop-2.38.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnome-base/libgtop/libgtop-2.38.0.ebuild b/gnome-base/libgtop/libgtop-2.38.0.ebuild
new file mode 100644
index 000000000000..5a13f2cabe7a
--- /dev/null
+++ b/gnome-base/libgtop/libgtop-2.38.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2
+
+DESCRIPTION="A library that provides top functionality to applications"
+HOMEPAGE="https://git.gnome.org/browse/libgtop"
+
+LICENSE="GPL-2"
+SLOT="2/11" # libgtop soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Add explicit stdc, bug #628256
+ append-cflags "-std=c99"
+
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}