summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-characters/gnome-characters-41.0.ebuild')
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-41.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/gnome-characters-41.0.ebuild b/gnome-extra/gnome-characters/gnome-characters-41.0.ebuild
new file mode 100644
index 000000000000..7a9d043376a6
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-41.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=dev-libs/libunistring-0.9.5:=
+ >=x11-libs/gtk+-3.20:3[introspection]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+ gnome-base/gnome-desktop:3[introspection]
+ >=gui-libs/libhandy-1.1:1=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}