summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/yelp/yelp-3.18.1-r1.ebuild')
-rw-r--r--gnome-extra/yelp/yelp-3.18.1-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/yelp/yelp-3.18.1-r1.ebuild b/gnome-extra/yelp/yelp-3.18.1-r1.ebuild
new file mode 100644
index 000000000000..fdf3179b8da2
--- /dev/null
+++ b/gnome-extra/yelp/yelp-3.18.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-3.12
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ epatch "${FILESDIR}"/${PN}-3.16.0-man-compatibility.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-bz2 \
+ --enable-lzma
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}