summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon-menus/Manifest1
-rw-r--r--gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-menus/Manifest b/gnome-extra/cinnamon-menus/Manifest
index 828a691fb63c..9605843c3ca8 100644
--- a/gnome-extra/cinnamon-menus/Manifest
+++ b/gnome-extra/cinnamon-menus/Manifest
@@ -1 +1,2 @@
DIST cinnamon-menus-3.6.0.tar.gz 180165 BLAKE2B a014c120bc84206914be69fcae0f4ec09b98a281012ed3f6f2f21f46762ea0b5e289c6dbd321fb7889f6172c9e7150673513e4c15dbd2e634c48efcefa816176 SHA512 dc90dbb8633ac77f4c8be7b013e3d6f9ba8f4e830f7e8c09ec7dcb9566a3768171a59cdc90b6cd11ad015b93629cdf6fc8c2397656f74603a517c0fbc97d3b14
+DIST cinnamon-menus-3.8.2.tar.gz 181252 BLAKE2B 9f91d22760d0ee13ce968dc0b553d2bbd8ead94169baf4bc8d4157e23225ec0a9e70d2eff22975aec6c2985517391b5e6293fd630e038061d313098320a8a498 SHA512 ce75e4076fbedffa998654537520dd0efa146ae4419d76921bf7de44a1b16c3431cc819a55436bfa038947d21f83cda37dc56fab5dcb372a90ca8a3850271868
diff --git a/gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild b/gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild
new file mode 100644
index 000000000000..35270ece27e1
--- /dev/null
+++ b/gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2
+
+DESCRIPTION="Cinnamon's library for the Desktop Menu fd.o specification"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-menus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ --disable-static
+}