summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps/terminal/terminal-0.9.7.ebuild')
-rw-r--r--gnustep-apps/terminal/terminal-0.9.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnustep-apps/terminal/terminal-0.9.7.ebuild b/gnustep-apps/terminal/terminal-0.9.7.ebuild
new file mode 100644
index 000000000000..1c665ebcace6
--- /dev/null
+++ b/gnustep-apps/terminal/terminal-0.9.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit gnustep-2
+
+S=${WORKDIR}/${P/t/T}
+
+DESCRIPTION="A terminal emulator for GNUstep"
+HOMEPAGE="http://www.nongnu.org/terminal/"
+SRC_URI="http://savannah.nongnu.org/download/gap/${P/t/T}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!<x11-terms/terminal-0.6.0" #376257
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Correct link command for --as-needed
+ sed -i -e "s/Terminal_LDFLAGS/ADDITIONAL_TOOL_LIBS/" GNUmakefile || die "sed failed"
+}