summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/aclock/aclock-0.4.0-r2.ebuild24
-rw-r--r--gnustep-apps/aclock/files/aclock-0.4.0-init.patch23
-rw-r--r--gnustep-apps/affiche/affiche-0.6.0-r4.ebuild15
-rw-r--r--gnustep-apps/affiche/affiche-0.6.0-r5.ebuild4
-rw-r--r--gnustep-apps/fisicalab/Manifest1
-rw-r--r--gnustep-apps/fisicalab/fisicalab-0.4.0.ebuild19
-rw-r--r--gnustep-apps/gnumail/Manifest1
-rw-r--r--gnustep-apps/gnumail/gnumail-1.3.0.ebuild33
-rw-r--r--gnustep-apps/gnumail/gnumail-1.4.0.ebuild4
-rw-r--r--gnustep-apps/gorm/Manifest2
-rw-r--r--gnustep-apps/gorm/gorm-1.3.1.ebuild4
-rw-r--r--gnustep-apps/gorm/gorm-1.4.0.ebuild (renamed from gnustep-apps/gorm/gorm-1.2.23.ebuild)10
-rw-r--r--gnustep-apps/gshisen/gshisen-1.3.0-r1.ebuild17
-rw-r--r--gnustep-apps/gshisen/gshisen-1.3.0-r2.ebuild4
-rw-r--r--gnustep-apps/gworkspace/gworkspace-1.0.0.ebuild4
-rw-r--r--gnustep-apps/preview/preview-0.9-r1.ebuild4
-rw-r--r--gnustep-apps/preview/preview-0.9.ebuild27
-rw-r--r--gnustep-apps/price/price-1.3.0-r1.ebuild6
-rw-r--r--gnustep-apps/price/price-1.3.0.ebuild19
-rw-r--r--gnustep-apps/projectcenter/projectcenter-0.7.0.ebuild4
-rw-r--r--gnustep-apps/simpleagenda/simpleagenda-0.46.ebuild4
21 files changed, 92 insertions, 137 deletions
diff --git a/gnustep-apps/aclock/aclock-0.4.0-r2.ebuild b/gnustep-apps/aclock/aclock-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..96b7f4ecaec9
--- /dev/null
+++ b/gnustep-apps/aclock/aclock-0.4.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnustep-2
+
+MY_P="${P/ac/AC}"
+DESCRIPTION="Analog dockapp clock for GNUstep"
+HOMEPAGE="http://gap.nongnu.org/aclock/"
+SRC_URI="https://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-init.patch )
+
+gnustep_config_script() {
+ echo "echo ' * using smooth seconds'"
+ echo "defaults write AClock SmoothSeconds YES"
+ echo "echo ' * setting refresh rate to 0.1 seconds'"
+ echo "defaults write AClock RefreshRate 0.1"
+}
diff --git a/gnustep-apps/aclock/files/aclock-0.4.0-init.patch b/gnustep-apps/aclock/files/aclock-0.4.0-init.patch
new file mode 100644
index 000000000000..45961369c09d
--- /dev/null
+++ b/gnustep-apps/aclock/files/aclock-0.4.0-init.patch
@@ -0,0 +1,23 @@
+diff -Naur AClock-0.4.0.orig/AppController.m AClock-0.4.0/AppController.m
+--- AClock-0.4.0.orig/AppController.m 2011-07-01 13:00:12.000000000 +0200
++++ AClock-0.4.0/AppController.m 2024-07-21 23:27:31.977296966 +0200
+@@ -25,6 +25,7 @@
+ */
+
+ #import <AppKit/AppKit.h>
++#import <GNUstepGUI/GSInfoPanel.h>
+ #import "AppController.h"
+
+ @implementation AppController
+diff -Naur AClock-0.4.0.orig/Clock.m AClock-0.4.0/Clock.m
+--- AClock-0.4.0.orig/Clock.m 2011-07-01 13:00:23.000000000 +0200
++++ AClock-0.4.0/Clock.m 2024-07-21 23:27:31.977296966 +0200
+@@ -50,7 +50,7 @@
+ RETAIN(numArray[0]);
+ RETAIN(numArray[1]);
+
+- dayWeek = [NSArray arrayWithObjects:@"su",@"mo",@"tu",@"we",@"th",@"fr",@"sa"];
++ dayWeek = [NSArray arrayWithObjects:@"su",@"mo",@"tu",@"we",@"th",@"fr",@"sa",nil];
+ RETAIN(dayWeek);
+
+ defaults = [NSUserDefaults standardUserDefaults];
diff --git a/gnustep-apps/affiche/affiche-0.6.0-r4.ebuild b/gnustep-apps/affiche/affiche-0.6.0-r4.ebuild
deleted file mode 100644
index c35fb5b43927..000000000000
--- a/gnustep-apps/affiche/affiche-0.6.0-r4.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnustep-2
-
-DESCRIPTION="Affiche allows people to 'stick' notes"
-HOMEPAGE="http://www.collaboration-world.com/affiche"
-SRC_URI="http://www.collaboration-world.com/affiche.data/releases/Stable/${P/a/A}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-S=${WORKDIR}/${PN/a/A}
diff --git a/gnustep-apps/affiche/affiche-0.6.0-r5.ebuild b/gnustep-apps/affiche/affiche-0.6.0-r5.ebuild
index 2de498a0a255..27182089c641 100644
--- a/gnustep-apps/affiche/affiche-0.6.0-r5.ebuild
+++ b/gnustep-apps/affiche/affiche-0.6.0-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,4 +12,4 @@ S="${WORKDIR}/${PN/a/A}"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
diff --git a/gnustep-apps/fisicalab/Manifest b/gnustep-apps/fisicalab/Manifest
index 0499857a4011..852a8dbe53ed 100644
--- a/gnustep-apps/fisicalab/Manifest
+++ b/gnustep-apps/fisicalab/Manifest
@@ -1 +1,2 @@
DIST fisicalab-0.3.5.tar.gz 7801631 BLAKE2B a4c07f951620ade580dc788bb5380f400b95b71e69df87288836b8eb221b76998ec9214a23b2c75e39a46816deefa65a935b5196c9281008e1ac44924b29893b SHA512 03ac3f67c3597fda8418f6b5e7612c2b56cd90a5afd12834e57934a0a453f7afd7488ba0476af576275a3e2663389d4b18de590bfc954d2ca38af6c31cbd790b
+DIST fisicalab-0.4.0.tar.gz 4536949 BLAKE2B de6c66a056cdf4a6c09c80674ec358dd8b22af5e83a9354043eb810a1b8626ffb4c2f68f0af02ec097adff32914d47fe2caf241d22f7bc3056acf0e9f1bf1a7c SHA512 0eed9533fb329a8bfb2ef5099a705d77dce0eede79be78afd3c1f80880a5b4b8f16edb117e8fda0fe60684b1a683389f512abea11f0c2be6a92ac6499035bdb2
diff --git a/gnustep-apps/fisicalab/fisicalab-0.4.0.ebuild b/gnustep-apps/fisicalab/fisicalab-0.4.0.ebuild
new file mode 100644
index 000000000000..5bb126268b25
--- /dev/null
+++ b/gnustep-apps/fisicalab/fisicalab-0.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnustep-2
+
+DESCRIPTION="educational application to solve physics problems"
+HOMEPAGE="https://www.gnu.org/software/fisicalab"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+S=${WORKDIR}/trunk
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="gnustep-libs/renaissance
+ >=sci-libs/gsl-1.10
+ >=virtual/gnustep-back-0.31.0"
+RDEPEND="${DEPEND}"
diff --git a/gnustep-apps/gnumail/Manifest b/gnustep-apps/gnumail/Manifest
index 4dbe75612fed..a428d451fe4c 100644
--- a/gnustep-apps/gnumail/Manifest
+++ b/gnustep-apps/gnumail/Manifest
@@ -1,2 +1 @@
-DIST GNUMail-1.3.0.tar.gz 1499242 BLAKE2B 074b83fd5fc9599ccae8a9f286db77ce4d61db7bbc9c33d1fd86cef818831d05b297c598c776ec0254a379daa8fc73776857ff2578ec2e83835c5525def459f8 SHA512 9b3ccf0a2e086129d8f96cf1de38ceb16033ef4509c3fe15af2afe43c31eaad32d121c0f9cf53f3d86472067d4207736523a125162e632572c7d1aee1fbefd78
DIST GNUMail-1.4.0.tar.gz 1873175 BLAKE2B c87efb48b30c1d5fa40789d7db3165e1be2c1b9847ed3e71cca28e90fe353ee562709c93ad10a6cb6284338f66f6786286f613a398669d22abbee63da97de1e5 SHA512 c6b8b94462a5d5620586e38b50030ed8dda4a54286e9fa38f68159c54e6c72e8ad470ff63394b8dc2649da63b3164b52ff072298a794622b6e0b32b7e29de991
diff --git a/gnustep-apps/gnumail/gnumail-1.3.0.ebuild b/gnustep-apps/gnumail/gnumail-1.3.0.ebuild
deleted file mode 100644
index c76e64581de7..000000000000
--- a/gnustep-apps/gnumail/gnumail-1.3.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnustep-2
-
-MY_P=${P/gnum/GNUM}
-
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A fully featured mail application for GNUstep"
-HOMEPAGE="http://www.nongnu.org/gnustep-nonfsf/gnumail/"
-SRC_URI="mirror://nongnu/gnustep-nonfsf/${MY_P}.tar.gz"
-KEYWORDS="amd64 ppc x86"
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="crypt"
-DEPEND=">=gnustep-base/gnustep-gui-0.11.0
- =gnustep-libs/pantomime-1.3*
- gnustep-apps/addresses"
-RDEPEND="crypt? ( app-crypt/gnupg )"
-
-src_prepare() {
- use crypt || sed -i -e 's|Bundles/PGP||' GNUmakefile || die
-
- default
-}
-
-src_install() {
- gnustep-base_src_install
- dodoc "${S}"/Documentation/*
-}
diff --git a/gnustep-apps/gnumail/gnumail-1.4.0.ebuild b/gnustep-apps/gnumail/gnumail-1.4.0.ebuild
index dbc1c2cb26d8..57975494dcd7 100644
--- a/gnustep-apps/gnumail/gnumail-1.4.0.ebuild
+++ b/gnustep-apps/gnumail/gnumail-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ HOMEPAGE="https://www.nongnu.org/gnustep-nonfsf/gnumail/"
SRC_URI="mirror://nongnu/gnustep-nonfsf/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
LICENSE="GPL-2+"
SLOT="0"
diff --git a/gnustep-apps/gorm/Manifest b/gnustep-apps/gorm/Manifest
index cb058a5af256..7ffe910b59e8 100644
--- a/gnustep-apps/gorm/Manifest
+++ b/gnustep-apps/gorm/Manifest
@@ -1,3 +1,3 @@
-DIST gorm-1.2.23.tar.gz 695799 BLAKE2B 93fcf72088a45c553fce4473a489719c84f02aa510e8da6fe4a1bbc80f1fab7d07ac07e05e6a543eaf5340246de4022b0be01fd0aaf48ac327aa52f723838074 SHA512 785ba83a82cee982c688a185300e90c9973b1c3de262770e708199593e7d8bfd9dccfa48ff6951f5d87558dffdda67c70fbc5091504afdd93e6e043d7b134460
DIST gorm-1.2.28.tar.gz 9158263 BLAKE2B 09e49bfb1329a1da0b379987e4b8ce6a69959d83c676b01829c18db543e5fc9c346230deb188153dde4e5257c47ec5e84aee008701a3a4b77bfc3ace132bd662 SHA512 0125e1c86f7158a647f65c3e1d6c9f167b7a58055a87b837ca44a14cc84c02edbc8472ba5362776fc05c000ac010189531738efec3952df7d2edf9a3d0328e6b
DIST gorm-1.3.1.tar.gz 7090395 BLAKE2B 55abb7a6e367e5e100d30edc3abda0b8e0903ad71d01952131e4ab7b565c8bec944126f3b8932e1cc24a16e76ce0e55291d1bab59ea03b1c41e14dda070de500 SHA512 9c2474e01145cbe8ae97e00baa7aa8c114b2fe3853b44c9e893eeef444dd7e2fe036111a8d09745c3e624383e8e5e692a8d7cc845cc6c85860f111e54f085e00
+DIST gorm-1.4.0.tar.gz 770167 BLAKE2B 38e17454ae1a73dce7818731b4e10b62f2a5b2070b1a111c5d0ffadbb13c753fb077f0ce192e72bc948e10e7299397f165d8074d2707d52cd697181bceda1c1f SHA512 5d816a381759b89465aacadbf0d5f82630201db428e29dd11418f6ad52f3fc2ddc25e907470deffd5e564fb0c56d70d120ab9dea9b6df64cf3e58652025a4dad
diff --git a/gnustep-apps/gorm/gorm-1.3.1.ebuild b/gnustep-apps/gorm/gorm-1.3.1.ebuild
index fbbe5b24ba78..ebd3bfa583e4 100644
--- a/gnustep-apps/gorm/gorm-1.3.1.ebuild
+++ b/gnustep-apps/gorm/gorm-1.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ DESCRIPTION="A clone of the NeXTstep Interface Builder application for GNUstep"
HOMEPAGE="https://gnustep.github.io/experience/Gorm.html"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/dev-apps/${P}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
IUSE=""
diff --git a/gnustep-apps/gorm/gorm-1.2.23.ebuild b/gnustep-apps/gorm/gorm-1.4.0.ebuild
index cd46294de349..a94bb1e8ab39 100644
--- a/gnustep-apps/gorm/gorm-1.2.23.ebuild
+++ b/gnustep-apps/gorm/gorm-1.4.0.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit gnustep-2
DESCRIPTION="A clone of the NeXTstep Interface Builder application for GNUstep"
HOMEPAGE="https://gnustep.github.io/experience/Gorm.html"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/dev-apps/${P}.tar.gz"
-KEYWORDS="amd64 ppc x86"
+S=${WORKDIR}/apps-${PN}-${PN}-${PV//./_}
LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND=">=gnustep-base/gnustep-gui-0.22.0"
+DEPEND=">=gnustep-base/gnustep-gui-0.31.0"
RDEPEND="${DEPEND}"
src_prepare() {
diff --git a/gnustep-apps/gshisen/gshisen-1.3.0-r1.ebuild b/gnustep-apps/gshisen/gshisen-1.3.0-r1.ebuild
deleted file mode 100644
index c0fa51d3b218..000000000000
--- a/gnustep-apps/gshisen/gshisen-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnustep-2
-
-MY_PN=GShisen
-DESCRIPTION="The first GNUstep game, similar to Mahjongg"
-HOMEPAGE="http://gap.nongnu.org/gshisen/index.html"
-SRC_URI="https://savannah.nongnu.org/download/gap/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_PN}-${PV}
diff --git a/gnustep-apps/gshisen/gshisen-1.3.0-r2.ebuild b/gnustep-apps/gshisen/gshisen-1.3.0-r2.ebuild
index 10ec9ec20586..ea02dd897bb8 100644
--- a/gnustep-apps/gshisen/gshisen-1.3.0-r2.ebuild
+++ b/gnustep-apps/gshisen/gshisen-1.3.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,4 +13,4 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
diff --git a/gnustep-apps/gworkspace/gworkspace-1.0.0.ebuild b/gnustep-apps/gworkspace/gworkspace-1.0.0.ebuild
index 1fa9b251038a..eab3c2b40ec5 100644
--- a/gnustep-apps/gworkspace/gworkspace-1.0.0.ebuild
+++ b/gnustep-apps/gworkspace/gworkspace-1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ DESCRIPTION="A workspace manager for GNUstep"
HOMEPAGE="https://gnustep.github.io/experience/GWorkspace.html"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/usr-apps/${P}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
LICENSE="GPL-2"
SLOT="0"
diff --git a/gnustep-apps/preview/preview-0.9-r1.ebuild b/gnustep-apps/preview/preview-0.9-r1.ebuild
index 727f32123ad6..7d565c0db321 100644
--- a/gnustep-apps/preview/preview-0.9-r1.ebuild
+++ b/gnustep-apps/preview/preview-0.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ S="${WORKDIR}/${PN/p/P}"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
PATCHES=(
# Fix compilation, patch from debian
diff --git a/gnustep-apps/preview/preview-0.9.ebuild b/gnustep-apps/preview/preview-0.9.ebuild
deleted file mode 100644
index f7bac95e785d..000000000000
--- a/gnustep-apps/preview/preview-0.9.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnustep-2
-
-DESCRIPTION="Simple image viewer"
-HOMEPAGE="http://www.sonappart.net/softwares/preview/"
-SRC_URI="http://www.sonappart.net/softwares/preview/download/${P/p/P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-S=${WORKDIR}/${PN/p/P}
-
-PATCHES=(
- # Fix compilation, patch from debian
- "${FILESDIR}"/${PN}-0.8.5-compilation-errors.patch
-)
-
-src_prepare() {
- default
- sed -e 's/sel_eq(/sel_isEqual(/' -i Document.m || die
-}
diff --git a/gnustep-apps/price/price-1.3.0-r1.ebuild b/gnustep-apps/price/price-1.3.0-r1.ebuild
index b09d961a57f6..b4ed58741176 100644
--- a/gnustep-apps/price/price-1.3.0-r1.ebuild
+++ b/gnustep-apps/price/price-1.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,10 +8,10 @@ inherit gnustep-2
MY_P=PRICE-${PV}
DESCRIPTION="Precision Raster Image Convolution Engine"
HOMEPAGE="https://price.sourceforge.net/"
-SRC_URI="mirror://sourceforge/price/${MY_P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/price/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
SLOT="0"
LICENSE="GPL-2+"
diff --git a/gnustep-apps/price/price-1.3.0.ebuild b/gnustep-apps/price/price-1.3.0.ebuild
deleted file mode 100644
index ad33ba82eaf9..000000000000
--- a/gnustep-apps/price/price-1.3.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnustep-2
-
-MY_P=PRICE-${PV}
-DESCRIPTION="Precision Raster Image Convolution Engine"
-HOMEPAGE="https://price.sourceforge.net/"
-SRC_URI="mirror://sourceforge/price/${MY_P}.tar.gz"
-KEYWORDS="amd64 ~ppc x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND=">=gnustep-base/gnustep-gui-0.13.0"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
diff --git a/gnustep-apps/projectcenter/projectcenter-0.7.0.ebuild b/gnustep-apps/projectcenter/projectcenter-0.7.0.ebuild
index 45d1ff0c2863..181595d98b7b 100644
--- a/gnustep-apps/projectcenter/projectcenter-0.7.0.ebuild
+++ b/gnustep-apps/projectcenter/projectcenter-0.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ DESCRIPTION="An IDE for GNUstep"
HOMEPAGE="https://gnustep.github.io/experience/ProjectCenter.html"
SRC_URI="https://github.com/gnustep/apps-projectcenter/releases/download/projectcenter-${PV//./_}/${P}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
diff --git a/gnustep-apps/simpleagenda/simpleagenda-0.46.ebuild b/gnustep-apps/simpleagenda/simpleagenda-0.46.ebuild
index 99479a8426d4..adbfb999faae 100644
--- a/gnustep-apps/simpleagenda/simpleagenda-0.46.ebuild
+++ b/gnustep-apps/simpleagenda/simpleagenda-0.46.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/poroussel/simpleagenda/archive/v${PV}.tar.gz -> ${P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
IUSE="dbus"
DEPEND=">=dev-libs/libical-0.27