summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild')
-rw-r--r--gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild b/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
index af4957771143..b0aa579764ee 100644
--- a/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
+++ b/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnustep-base
+inherit gnustep-base toolchain-funcs
DESCRIPTION="A tool to create .nfont packages for use with gnustep-back-art"
HOMEPAGE="https://packages.debian.org/mknfonts.tool"
@@ -15,8 +15,8 @@ IUSE=""
RDEPEND="gnustep-base/gnustep-gui
>=media-libs/freetype-2.1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-rename.patch
@@ -26,6 +26,8 @@ PATCHES=(
src_prepare() {
default
+ tc-export PKG_CONFIG
+
# Correct link command for --as-needed
sed -i -e "s/ADDITIONAL_LDFLAGS/ADDITIONAL_TOOL_LIBS/" GNUmakefile || die
}