summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/pantomime/pantomime-1.2.2.ebuild')
-rw-r--r--gnustep-libs/pantomime/pantomime-1.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnustep-libs/pantomime/pantomime-1.2.2.ebuild b/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
new file mode 100644
index 000000000000..3c0efecfe8cd
--- /dev/null
+++ b/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnustep-2
+
+MY_P=${P/p/P}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A set of Objective-C classes that model a mail system"
+HOMEPAGE="http://www.collaboration-world.com/pantomime/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 Elm"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
+ Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd "${S}"/Documentation
+ dodoc AUTHORS README TODO
+ docinto rfc
+ dodoc RFC/*
+}