summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/swappy/swappy-1.4.0.ebuild')
-rw-r--r--gui-apps/swappy/swappy-1.4.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/gui-apps/swappy/swappy-1.4.0.ebuild b/gui-apps/swappy/swappy-1.4.0.ebuild
deleted file mode 100644
index 0a361465ffa6..000000000000
--- a/gui-apps/swappy/swappy-1.4.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson xdg optfeature
-
-DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
-HOMEPAGE="https://github.com/jtheoof/swappy"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/jtheoof/swappy"
-else
- SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
-"
-RDEPEND="${DEPEND}
- media-fonts/fontawesome[otf]
-"
-BDEPEND="
- app-text/scdoc
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=enabled
- )
- meson_src_configure
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
-}