summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/swaybg/swaybg-1.0.ebuild')
-rw-r--r--gui-apps/swaybg/swaybg-1.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/gui-apps/swaybg/swaybg-1.0.ebuild b/gui-apps/swaybg/swaybg-1.0.ebuild
deleted file mode 100644
index 102d9f6f0524..000000000000
--- a/gui-apps/swaybg/swaybg-1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A wallpaper utility for Wayland"
-HOMEPAGE="https://github.com/swaywm/swaybg"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man"
-
-DEPEND="
- dev-libs/wayland
-"
-RDEPEND="
- ${DEPEND}
- !<gui-wm/sway-1.1_alpha1
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.14
- x11-libs/gdk-pixbuf
- x11-libs/cairo
- virtual/pkgconfig
- man? ( app-text/scdoc )
-"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=$(usex man enabled disabled)
- )
-
- meson_src_configure
-}