summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/waybar/waybar-9999.ebuild')
-rw-r--r--gui-apps/waybar/waybar-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/gui-apps/waybar/waybar-9999.ebuild b/gui-apps/waybar/waybar-9999.ebuild
index 8cd23063c51d..eb00704854ae 100644
--- a/gui-apps/waybar/waybar-9999.ebuild
+++ b/gui-apps/waybar/waybar-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson
-DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
HOMEPAGE="https://github.com/Alexays/Waybar"
if [[ ${PV} == 9999 ]]; then
@@ -18,13 +18,12 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="mpd network pulseaudio tray +udev"
+IUSE="mpd network popups pulseaudio tray +udev"
BDEPEND="
>=app-text/scdoc-1.9.2
virtual/pkgconfig
-"
-
+ "
DEPEND="
dev-cpp/gtkmm:3.0
dev-libs/jsoncpp:=
@@ -32,26 +31,27 @@ DEPEND="
dev-libs/libsigc++:2
>=dev-libs/libfmt-5.3.0:=
>=dev-libs/spdlog-1.3.1:=
+ dev-libs/date
dev-libs/wayland
dev-libs/wayland-protocols
gui-libs/wlroots
mpd? ( media-libs/libmpdclient )
network? ( dev-libs/libnl:3 )
+ popups? ( gui-libs/gtk-layer-shell )
pulseaudio? ( media-sound/pulseaudio )
- tray? ( dev-libs/libdbusmenu[gtk3] )
+ tray? (
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/libappindicator
+ )
udev? ( virtual/libudev:= )
-"
-
+ "
RDEPEND="${DEPEND}"
-if [[ ${PV} != 9999 ]]; then
- S="${WORKDIR}/${PN^}-${PV}"
-fi
-
src_configure() {
local emesonargs=(
$(meson_feature mpd)
$(meson_feature network libnl)
+ $(meson_feature popups gtk-layer-shell)
$(meson_feature pulseaudio)
$(meson_feature tray dbusmenu-gtk)
$(meson_feature udev libudev)