summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wf-shell/wf-shell-0.4.0.ebuild')
-rw-r--r--gui-apps/wf-shell/wf-shell-0.4.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gui-apps/wf-shell/wf-shell-0.4.0.ebuild b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
new file mode 100644
index 000000000000..9167682d0b61
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio debug"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ ~gui-wm/wayfire-${PV}
+ >=gui-libs/gtk-layer-shell-0.1
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}