summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wf-shell/wf-shell-0.7.0.ebuild')
-rw-r--r--gui-apps/wf-shell/wf-shell-0.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gui-apps/wf-shell/wf-shell-0.7.0.ebuild b/gui-apps/wf-shell/wf-shell-0.7.0.ebuild
new file mode 100644
index 000000000000..11f54e22daca
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ gui-libs/gtk-layer-shell
+ >=gui-wm/wayfire-${PV%.*}
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}