summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wf-shell/wf-shell-9999.ebuild')
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
index 0734bbb0cb13..1cfcb8cbb345 100644
--- a/gui-apps/wf-shell/wf-shell-9999.ebuild
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -11,20 +11,27 @@ HOMEPAGE="https://github.com/WayfireWM/wf-shell"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
IUSE="+pulseaudio"
+# no tests
+RESTRICT="test"
+
DEPEND="
- dev-cpp/gtkmm:3.0=[wayland]
+ dev-cpp/gtkmm:3.0[wayland]
dev-libs/gobject-introspection
- gui-libs/gtk-layer-shell
- >=gui-wm/wayfire-${PV%.*}
+ dev-libs/libdbusmenu
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}