summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wf-shell')
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.5.0.ebuild43
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild3
3 files changed, 45 insertions, 2 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index e210eeae0b99..1df1fef29e60 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1 +1,2 @@
DIST wf-shell-0.4.0.tar.xz 8996656 BLAKE2B 609668bcf00fcc7a0b8142d84a7101f07578c2d6a88616da286a615076372e5a356387cf5e3fdee9b4aba6f027d8d081a5cce32f7f00682a756d4ee9bc46916d SHA512 1b293ce3fc2b12acbadb75e0de28217ed24f733e26d7ad12ada9a5f0673df911e75eea5af6841c466f031151f881a8e36dda229ea4dc2f91825e2e6df42d4903
+DIST wf-shell-0.5.0.tar.xz 8998296 BLAKE2B c32232fc08292b15a0048d11d0f179a82fd21b3179223d898057ac95b42ac35ec063467f67c0f1261857c3b643edc4367112a05bb63f002788b64ed86559addd SHA512 d0029746ea10625bb47381a7ed74aadb8aa3823f83f751b539eefd49da5aa1643a2d16c55fe23d30bd71528ad5c1ea8d389909fe8cc1026746b3b76aa5dabd2b
diff --git a/gui-apps/wf-shell/wf-shell-0.5.0.ebuild b/gui-apps/wf-shell/wf-shell-0.5.0.ebuild
new file mode 100644
index 000000000000..94c26507f32a
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ >=gui-libs/gtk-layer-shell-0.1
+ >=gui-wm/wayfire-${PV}
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
index 21fc54e4ef78..94c26507f32a 100644
--- a/gui-apps/wf-shell/wf-shell-9999.ebuild
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -23,15 +23,14 @@ IUSE="+pulseaudio"
DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
- ~gui-wm/wayfire-${PV}
>=gui-libs/gtk-layer-shell-0.1
+ >=gui-wm/wayfire-${PV}
pulseaudio? ( media-sound/pulseaudio )
"
RDEPEND="${DEPEND}"
BDEPEND="
- ${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"