summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/wf-config/wf-config-0.4.0.ebuild')
-rw-r--r--gui-libs/wf-config/wf-config-0.4.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/gui-libs/wf-config/wf-config-0.4.0.ebuild b/gui-libs/wf-config/wf-config-0.4.0.ebuild
deleted file mode 100644
index b52ae6b08e27..000000000000
--- a/gui-libs/wf-config/wf-config-0.4.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="library for managing wayfire configuration files"
-HOMEPAGE="https://github.com/WayfireWM/wf-config"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
-else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="debug"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/libxml2
- media-libs/glm
- <=gui-libs/wlroots-0.10.1
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- ${DEPEND}
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
-
-src_configure () {
- local emesonargs=""
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
- meson_src_configure
-}