summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/wf-config/wf-config-0.6.0.ebuild')
-rw-r--r--gui-libs/wf-config/wf-config-0.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-libs/wf-config/wf-config-0.6.0.ebuild b/gui-libs/wf-config/wf-config-0.6.0.ebuild
new file mode 100644
index 000000000000..fdcbe17d4da5
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ >=gui-libs/wlroots-0.12.0
+ media-libs/glm
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"